Search by rating is unavailable on prod

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: krupa, Assigned: chizu)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 410014 [details]
screenshot

steps to reproduce:
try to sort search results by "rating"


observed behavior:
"Search is temporarily unavailable" message is displayed

sorting by "keyword match" works fine
we need IT help with this, not sure what's going on.  Is sphinx working?
Assignee: dd → server-ops
Component: Public Pages → Server Operations
Product: addons.mozilla.org → mozilla.org
QA Contact: web-ui → mrz
Target Milestone: 5.3 → ---
Version: unspecified → other
Assignee: server-ops → aravind
According to the docs I have, sphinx should be working if search on addons.m.o works.  I just verified that search works there.

Also, not sure how bugs like this are blocker.  Sure, the site is missing functionality, but that alone doesn't warranty a blocker.
Severity: blocker → major
So the real issue here isn't that Sphinx is down, but the sphinx query is being formulated strangely or incorrectly.

Unfortunately sphinx doesn't give us much in the way of debugging errors like this if we can't duplicate them in our dev sites or preview.

So where we need help is debugging this problem which only shows up in production.

If possible, could we  pull a box out of rotation, enable debugging and figure out what's going on?
Severity: major → blocker

Comment 4

8 years ago
Is bug 483416 close to being done?  Could use that one.

Dash, what do you need to troubleshoot/solve this?
Just a single production box (or even a new buildout) that shows these same issues.

The DEBUG for cake needs to be set at 2, and this needs to *not* be served live since debug data will be displayed.

If I *can't* figure out from the DEBUG info what's going on, I may need shell access.

Independently I do need to provide better logging in the errorlog - so I'll work on that.
Severity: blocker → major
Talked to mrz, and wil,

If we can pull this out sooner than later that'd be great - it's worth doing before 5.3, since this page gets a fair amount of traffic.  Should be a quick fix with a possible patch - that may need to land in production ahead of 5.3.

-d
(In reply to comment #2)
> Also, not sure how bugs like this are blocker.  Sure, the site is missing
> functionality, but that alone doesn't warranty a blocker.

It was filed as a blocker in the AMO component and the severity was just carried over.
Talked to ddash, will pick this up tomorrow when I am at the office.
ddash has access to a production server now.
Trevor,

With Aravind's help, I chased this down - my suspicion is production is using a version of the sphinx.conf that doesn't work correctly.

I can possibly check in a version that should work, or you can revert to r53851.

I think preferably reverting would be best.

-d
According to ddash, Trevor knows all!
Assignee: aravind → thardcastle
(Assignee)

Comment 12

8 years ago
Reverted and it seems to work now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified FIXED.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.