In print preview, single-clicking bottom of scrollbar triggers continuous scrolling

VERIFIED FIXED

Status

()

Core
Print Preview
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
STEPS TO REPRODUCE:
 1. Print-preview any page (e.g. about:blank)
 2. If there aren't already scrollbars, shrink your Firefox window so that there are.
 3. Try to click and drag one of the scrollbars (either horizontal or vertical)

ACTUAL RESULTS: Clicking and dragging the scrollbar has no effect
EXPECTED RESULTS: It should scroll the print-preview view.

REGRESSION RANGE:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090913 Minefield/3.7a1pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090914 Minefield/3.7a1pre
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bf0fdec8f43b&tochange=912c6ae3b70c

I suspect bug 513318 or bug 503943.
(Reporter)

Comment 1

9 years ago
Here's a related issue, with the same regression range:

STEPS TO REPRODUCE:
 1. Print-preview http://www.gutenberg.org/files/11/11.txt (or any multipage doc)
   [I'm assuming there will be scrollbars since it's many pages long]
 2. Single-click at the very bottom of the scrollbar (just above the downarrow button)

ACTUAL RESULTS: Page starts scrolling downwards, and it **continues** scrolling downwards until I move mouse off of the scrollbar area.
(Reporter)

Comment 2

9 years ago
Mook confirmed both issues (Comment 0 & Comment 1) on Windows:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091103 Minefield/3.7a1pre (nightly)
 OS --> All
OS: Linux → All
Hardware: x86 → All
(Reporter)

Comment 3

9 years ago
Looks like bug 520501 is already filed about the issue described in comment 0, so I'm reshaping this bug here to be about the related issue in Comment 1.
Depends on: 520501
Summary: In print preview, clicking and dragging scrollbar doesn't scroll → In print preview, single-clicking bottom of scrollbar triggers continuous scrolling
(Reporter)

Comment 4

9 years ago
Confirmed that this (both comment 1 & 0) is a regression from bug 503943, by generating targeted builds.

A build from eda2433181c9 is broken, but its parent (8afb65205203) is fine.
Blocks: 503943

Comment 5

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091212 Minefield/3.7a1pre

Fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
Verified fixed:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091213 Minefield/3.7a1pre

Like bug 520501, this was almost certainly fixed by bug 487667. Marking dependency.
Status: RESOLVED → VERIFIED
Depends on: 487667
You need to log in before you can comment on or make changes to this bug.