Unable to use FileUtils.jsm in nsExtensionManager.js.in on 1.9.2 due to reftest failures

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

1.9.2 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

FileUtils.jsm was created in Bug 521452 and nsExtensionManager.js.in, nsBlocklistService.js, and nsUpdateService.js.in were all modified to use it. This worked fine on trunk but for some unknown reason (as of yet) it caused reftest failures on 1.9.2 so I backed out the changes to nsExtensionManager.js.in on 1.9.2.
The backout of the nsExtensionManager.js.in portion
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0c33b8654be4
One other item of interest is that mochitests passed without any problems.
btw: the set as default browser ui was displayed on the tinderboxes. I looked at the reftest profile and it didn't have the prefs set by automation.py.
this is really weird. which reftests were failing? are you sure was related to this particular landing?

you could push to try, and it should fail there if it was this change right?
The reftests wouldn't even start and I was able to reproduce locally. The prefs set by automation.py weren't set in the profile. I'll try to find the time to debug this over the next couple of days.
This only affects the mozilla-1.9.2 branch and I don't see much value in fixing this besides interest in knowing why it doesn't work on the mozilla-1.9.2 branch since it doesn't affect trunk. I'm leaving it open but afaic this is wontfix since a fix would provide little value as compared to risk on the branch.
Yeah I agree with this. Unless you think it is likely that this is revealing some more important issue that we aren't aware of (and it is worth the time to find that) then there doesn't seem to be much reason to work further on this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.