If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 3.6 beta 1 - XUL windows with iframe - left mouse button problem

RESOLVED DUPLICATE of bug 520535

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED DUPLICATE of bug 520535
8 years ago
8 years ago

People

(Reporter: ekzot, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.27 Safari/532.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1




Reproducible: Always

Steps to Reproduce:
1. Open XUL window with iframe using window.openDialog with titlebar=no
2.
3.
Actual Results:  
Nothing happens in loaded html when I click to eg. button (have onClick).

Expected Results:  
Everything works like in FF2, FF3 & FF3.5

Have xul window opened by my extension on button click. XUL window contains one iframe.

<window id="HTMLWindow" 
  xmlns:html="http://www.w3.org/1999/xhtml"
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
  hidechome="yes" style="background-color: white; border: 0px; padding: 0px; margin: 0px;" >

  <vbox flex="1" >
	<hbox  >
	</hbox>
	<hbox flex="1" >
		<iframe id="contFrame" src="" flex="1"  />
	</hbox>
  </vbox>
  
<script>
	...
	var ff = ...
	contFrame.setAttribute("src","some_local_html_file");
	...
</script>
 
</window>


Window opened with window.openDialog("file.xul",...);

When I set titlebar=yes, everything work fine, in case titlebar=no, iframe children don't catch click of mouse left button click (onClick doesn't work).

Works fine with FF2, FF3 and FF3.5.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Updated

8 years ago
Component: General → Extension Compatibility
(Reporter)

Comment 1

8 years ago
similar to
https://bugzilla.mozilla.org/show_bug.cgi?id=520535
QA Contact: general → extension.compatibility
(Reporter)

Updated

8 years ago
Flags: blocking-firefox3.6?
Same question about blocking and add-on compat as in bug 520535. Little help/input on expected compatibility hit?
Can't see any reason this isn't just a duplicate of the wider issue in bug 520535. Please reopen if I'm missing something.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Flags: blocking-firefox3.6?
Resolution: --- → DUPLICATE
Duplicate of bug: 520535
You need to log in before you can comment on or make changes to this bug.