CSS TEXTAREA width="100%" draws outside enclosing table

UNCONFIRMED
Unassigned

Status

()

Core
Layout
UNCONFIRMED
8 years ago
8 years ago

People

(Reporter: Glen Hoag, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows Vista
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)

A TEXTAREA element with a CSS width style of 100% is drawn outside the bounds of the enclosing table.  This seems to affect Windows only; I tested on Mac OS X and the expected behavior occurred.  The right edge of the TEXTAREA was drawn inside the border of the enclosing table.

Reproducible: Always

Steps to Reproduce:
See attached HTML example.
Actual Results:  
TEXTAREA right edge drawn past the right edge of the table enclosing it.

Expected Results:  
TEXTAREA right edge drawn one pixel to the left of the table enclosing it.
(Reporter)

Comment 1

8 years ago
Created attachment 410287 [details]
Example showing right edge of TEXTAREA drawn beyond the border of a table
(Reporter)

Comment 2

8 years ago
Created attachment 410290 [details]
Image showing TEXTAREA drawing problem.
(Reporter)

Comment 3

8 years ago
Created attachment 410296 [details]
Image showing TEXTAREA drawn correctly. (Firefox v3.5.4 Mac OS X)

Comment 4

8 years ago
Probably the same as bug 440415, which is about <input type="text">
Component: General → Layout
Depends on: 440415
Keywords: testcase
QA Contact: general → layout
Version: unspecified → Trunk
Yep, it's the same code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440415

Comment 6

8 years ago
Created attachment 443096 [details]
<textarea> vs <input type="text"> with width=100%

Since bug 440415 was marked as invalid, I don't think this is a dupe, because <input type="text"> doesn't show differences between Windows and Mac, while textarea does. See the attached testcase -- the textarea/input have the same width (sticking out of the table) on Windows, while on Mac the textarea is 3 px shorter and fits the table.

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

8 years ago
Created attachment 443097 [details]
screenshot of the above testcase on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100502 Minefield/3.7a5pre
(Reporter)

Comment 8

8 years ago
For what it's worth, I viewed Nickolay's test case on both Safari for Windows 4.0.5 and MSIE 7.0.6002.18005.  They both look like the Mac screenshot (<textarea> inside the table, and <input type "text"> sticking out).  

The inconsistency between platforms that I originally reported remains, and while the other two browsers can't be considered CSS validators, I believe that the problem should be resolved in the direction of making the Windows version work like the Mac version.
You need to log in before you can comment on or make changes to this bug.