modern2: scrollbar becomes white after pressing escape or stop

VERIFIED FIXED in M18

Status

()

P2
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: spam, Assigned: eric)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP2])

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
saw this yesterday as well a couple of times - now using 2000091408

to repro:
1: load todays bugs in bugzilla
2: scroll down to bottom
3: click "Find" button, and then quickly...
3: go to top of taskbar and click stop-button.

Result: the slidebar button becomes tiny.
If you now click on it, it will vanish.
So will the up/down arrow widgets on scrollbar.

(The scrollbar still works however)


If you have problems reconstructing, try some more times.
(Another error is how scrollbar can becomes completely unresponsive instead.
Reload and try from step 1)

Comment 1

18 years ago
->future
Target Milestone: --- → Future
(Reporter)

Comment 2

18 years ago
*** Bug 52731 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

18 years ago
i disagree with futuring this one. It is very common that users click stop
during a page-load, and it will become an extremely visible bug.
It affects the newmod theme. Clicking ESC has same effect, as observed in the
first dup.

Comment 4

18 years ago
Feel free to escalate the decision to pdt@netscape.com

Comment 5

18 years ago
Two notes: (1) this is only in one skin (newmod). (2) It is the images that 
disappear, not the scrollbar (i.e. scrolling remains fully functional, modulo
the fact that you're not entirely sure where the thumb, etc., is located. 
This is really a layout bug, I think.
(Reporter)

Comment 6

18 years ago
it may be related to the bug about vanishing buttons (bug 50652) again believed
to be caused by bug 51267 and maybe bug 51249 (just fixed).

Comment 7

18 years ago
->evaughan for possible reassignment to layout.
Assignee: trudelle → evaughan
(Reporter)

Comment 8

18 years ago
additional observation:
What vanishes first is the top and bottom of the scrollbar slider.
The middle of it (with the stripes) remains at this point. (Which is why it
looks so small.)
Clicking it will now make the rest of it disappear too, so will clicking
scrollbar arrows.

Comment 9

18 years ago
I've noticed this on windows too -> all/all.
Could this be related to the esc stopping animations?
OS: Linux → All
Hardware: PC → All
Summary: scrollbar widgets can vanish → scrollbar becomes white after pressing escape or stop

Comment 10

18 years ago
Should this be a "themes" bug because it happens only in new modern?
Keywords: newmod
Summary: scrollbar becomes white after pressing escape or stop → modern2: scrollbar becomes white after pressing escape or stop
(Reporter)

Comment 11

18 years ago
probably a "skinability" bug.
As for comment about animation: At the point ESC or stop-button is clicked the
scrollbar isn't animating anything.

I've seen a similar thing when stopping/ESC'ing pages with css;
both colors and images can vanish then. The scrollbar behaviour is likely
described in some .css file? Figuring out why those "faint" when load is stopped
may be the clue to solving this bug as well.

Comment 12

18 years ago
Eric, see comments by attinasi at end of bug 49222 (see also dup bug 48411, 
which was for exactly the problem of scrollbar images disappearing when the 
stop/esc is triggered).
(Assignee)

Comment 13

18 years ago
Well it looks like this happens because hitting the stop button stops all image 
loading even chrome. This wrong it should only apply to html and not the chrome 
in the html. Layout should not be doing this!

nominating for beta3
Status: NEW → ASSIGNED
Keywords: newmod → nsbeta3

Comment 14

18 years ago
nsbeta3+, P2: Highly visible, loss of basic functionality, workaround not
obvious to end-users.
Priority: P3 → P2
Whiteboard: [nsbeta3+]
Target Milestone: Future → M18
(Assignee)

Comment 15

18 years ago
I have a fix for this. I'll post a patch soon. Basically I added an argument 
called aStopChrome to Stop() in nsIPresContext. By default the argument is 
PR_TRUE. If you pass false it stops all images except those that point to chrome 
URLS. Currently all chrome URLs are local to your machine by definition so they 
can't be remote. I think this is a pretty safe solution for 6.0.
(Assignee)

Comment 16

18 years ago
Created attachment 15129 [details] [diff] [review]
Here is my proposed fixed. Please review

Comment 17

18 years ago
Regarding the patch: What is the deal with mImagesStopped on the PresContext?
The new member variable is never initialized and never set, but it is checked in
StartLoadImage? Am I missing something?
(Assignee)

Comment 18

18 years ago
Created attachment 15165 [details] [diff] [review]
Ok I screwed up and mailed an old patch. Look at this one.
(Assignee)

Comment 19

18 years ago
Ok all I did is add a variable called mStopChrome which recorded whether or not
chrome had been stopped. If it hasn't it will continue to allow chrome images to
be loaded.

I've tested this on windows and linix and it sees to work pretty well.

Comment 20

18 years ago
PDT agrees P2
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP2]
(Assignee)

Comment 21

18 years ago
fixed
(Assignee)

Comment 22

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 23

18 years ago
I think that was more of a chrome-specific workaround than a fix.  See bug 
53484 for some similar problems.
(Reporter)

Comment 24

18 years ago
well a chrome specific workaround was kinda required. Wonder if this will
improve the situation with vanishing buttons too.
When the whole GUI starts to fall apart when clicked on "at the wrong
time"...that's Bad. I hope 53484 is covered by 49222..

Comment 25

18 years ago
verified fixed. 20000921nn mac/linux/win32 -- can't get the chrome scrollbars
to white out, etc.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.