Cannot access Google Calendar anymore [Login failed. Status: 2147500037 NS_ERROR_FAILURE; Error Code -12263]

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Dorus Peelen, Unassigned)

Tracking

Lightning 0.9
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird Versie 2.0.0.23 (20090812)

Up to a week ago, the Provider voor Google Agenda 0.5.4 extension for thunderbird worked just fine. I could access my google calender from Lightning 0.9.

However, since 3 days now, i get a -12263 error when i try to connect to my agenda.

Adding the calender again doesn't solve this, adding a different (google) calender does request the username/password, but then again gives a -12263 error.

Reproducible: Always
Where does this error come from? In the error console?

Please enable calendar.debug.log and calendar.debug.log.verbose and then check your error console.
(Reporter)

Comment 2

8 years ago
It came in a pop-up, but will enable those 2 options tomorrow and post back the results :)
(Reporter)

Comment 3

8 years ago
Created attachment 410781 [details]
Screenshot of the error.

Here you go:

Adding item http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full to queue
Logging in to doruspeelen@mycompany.nl
Setting upload data for login request (hidden)
calGoogleRequest: Requesting POST https://www.google.com/accounts/ClientLogin
Adding item http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full to queue
Adding item http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full to queue
Adding item http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full to queue
Adding item http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full to queue
Login failed. Status: 2147500037
Failing queue with 2147500037
Recieved response for http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full
Error getting items:
[Exception... "null"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/DorusPeelen/Application%20Data/Thunderbird/Profiles/bvabu0nv.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/components/calGoogleCalendarModule.js -> file:///C:/Documents%20and%20Settings/DorusPeelen/Application%20Data/Thunderbird/Profiles/bvabu0nv.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleCalendar.js :: cGC_getItems_response :: line 829"  data: no]
Waarschuwing: Er is een fout opgetreden bij het lezen van gegevens voor agenda: doruspeelen@mycompany.nl.  Dit is waarschijnlijk een kleine fout, dus het programma zal proberen verder te gaan. Foutcode: 0x80004005. Beschrijving: null
Waarschuwing: Er is een fout opgetreden bij het lezen van gegevens voor agenda: doruspeelen@mycompany.nl.  Dit is waarschijnlijk een kleine fout, dus het programma zal proberen verder te gaan. Foutcode: READ_FAILED. Beschrijving: 
Recieved response for http://www.google.com/calendar/feeds/doruspeelen%40mycompany.nl/private/full
Waarschuwing: Er is een fout opgetreden bij het lezen van gegevens voor agenda: doruspeelen@mycompany.nl.  Dit is waarschijnlijk een kleine fout, dus het programma zal proberen verder te gaan. Foutcode: 0x80004005. Beschrijving: null


And it keeps going like this for a while.
Looks like a connection/authentication error to me. Wouldn't surprise me if the local firewall is to blame. Even then, authentication was correct last week, Thunderbird can receive email, and the original error message wasn't very informative.

ps. put the original error in the attachment and removed my companyname from the error log.

Updated

8 years ago
Summary: Google calender gives -12263 error. → Cannot access Google Calendar anymore [Login failed. Status: 2147500037 NS_ERROR_FAILURE; Error Code -12263]
Version: unspecified → Lightning 0.9
(Reporter)

Comment 4

8 years ago
I should not forget to mention that this is no longer happening. For quite some time now. I think the bug even disappeared without any setting changes or google calendar updates. My co-worker who had the same problem also reported the problem to go away randomly, and coming back too.

Anyway, for me it wend away completely sometimes in December i estimate.

Comment 5

8 years ago
Resolving as WORKSFORME. Feel to reopen the bug if the issues occurs again and if you can provide more information to investigate it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.