OK to AB card doesn't work, can't add card, hard to edit card.

VERIFIED WORKSFORME

Status

P2
major
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: spam, Assigned: scottputterman)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][dogfood-])

(Reporter)

Description

18 years ago
20000901408 linux M18

when editing address-book card, clicking OK only spawns:

JavaScript error:
 line 0: this.inputField has no properties

onEvent(blur)

The modifications made to the card are stored however, but it isn't exactly
intuitive that hitting "cancel" (like i did) saves anything at all.
(Reporter)

Comment 1

18 years ago
ahh forgot to tell the obvious: clicking OK at first seemingly *only* produce
the error, it didn't close the window.
(Reporter)

Comment 2

18 years ago
more descriptive summary
Summary: error when editing AB → OK button only give error when editing AB card

Updated

18 years ago
QA Contact: esther → suresh

Comment 3

18 years ago
Well, if you're adding a new card to the address book, instead of editing, the
OK still doesn't work and Cancel does not save anything.
Can't add cards! All platforms with sep14 commercial build

nominating dogfood, beta3 and changed summary to reflect most important of the
problems
Severity: normal → major
Keywords: dogfood, nsbeta3
Priority: P3 → P2
Summary: OK button only give error when editing AB card → OK to AB card doesn't work, can't add card, hard to edit card.

Comment 4

18 years ago
adding candice to the cc list.
Keywords: regression
(Reporter)

Comment 5

18 years ago
i wonder if this can be a more widespread problem: see bug 52707

Comment 6

18 years ago
Doesn't look to me as a widespread problem. I'm able to create a mailing list 
and Click OK.

Comment 7

18 years ago
There are rumors that this morning's builds were so bad we shouldn't file bugs 
against them.  Can we verify this against the most current good build?
Whiteboard: [b3 need repro]

Comment 8

18 years ago
I reproduced this with the current commercial build, which as far as I know is
OK to log bugs against.  I'm talking to esther now, and this is a valid bug for
today's posted commercial builds, they were put up on sweetlou at 1pm.

Comment 9

18 years ago
Changing to nsbeta3+ per discussion with laurel about build she used. 
Whiteboard: [b3 need repro] → [nsbeta3+]

Comment 10

18 years ago
This should not stop day-to-day dogfood use, since addresses are automatically
gathered in N6
Marking dogfood-minus
Whiteboard: [nsbeta3+] → [nsbeta3+][dogfood-]

Comment 11

18 years ago
Use today's debug mozilla build on my Linux and NT machine,  I don't see this 
problem.

Comment 12

18 years ago
I don't have the problem, either, with today's commercial build on all
platforms.  Will let Suresh confirm .

Comment 13

18 years ago
I don't see this problem either on all platforms using today's build. 
MArking WFM...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 14

18 years ago
..and Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.