Closed Bug 526921 Opened 10 years ago Closed 10 years ago

add-ons get installed before user confirmation

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

Fennec 1.1
x86
All
defect
Not set
blocker

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0
Tracking Status
fennec 1.0+ ---

People

(Reporter: fabrice.desre, Assigned: fabrice.desre)

Details

Attachments

(2 files, 1 obsolete file)

Add-ons from AMO sometimes get installed before the user confirms or cancels the install. The alert is displayed showing "Installing addons" and then "Installation complete".

Strangely I've only be able to reproduce this with experimental add-ons (see screenshot).

This is very dangerous since a naive user hitting "cancel" will end up with an installed add-on on the next restart without noticing anything.
Flags: wanted-fennec1.0?
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0+
Assignee: nobody → mark.finkle
I see this with recommended (i.e. URL Fixer and GeoGuide) add-ons too when installing from Mobile AMO.
Once  bug 528867 is fixed, this should be marked as blocking-fennec?
This is caused by an "unload" event that is caught by the dialog. 

The event has the following properties :
event.originalTarget = [object XPCNativeWrapper [object HTMLDocument]]
event.type = unload
event.target = [object XPCNativeWrapper [object HTMLDocument]]
event.currentTarget = [object ChromeWindow]
event.eventPhase = 1
event.bubbles = false
event.cancelable = true
event.timeStamp = 0

It looks like it bubbles from the web page ??
event.explicitOriginalTarget = [object XPCNativeWrapper [object HTMLSpanElement]]
Attached patch fix (obsolete) — Splinter Review
Ignore the event if it comes from HTMLDocument
Assignee: mark.finkle → fabrice.desre
Attachment #413564 - Flags: review?(mark.finkle)
Attached patch updated patchSplinter Review
Now checks that the event comes only from |document|
Attachment #413564 - Attachment is obsolete: true
Attachment #413618 - Flags: review?(mark.finkle)
Attachment #413564 - Flags: review?(mark.finkle)
Attachment #413618 - Flags: review?(mark.finkle) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/e2221b8c28a4
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b4pre) Gecko/20091123 Firefox/3.6b4pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091123 Firefox/3.7a1pre Fennec/1.0b5


...filed a follow-up bug https://bugzilla.mozilla.org/show_bug.cgi?id=530549 as an edge case was found during verification.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.