Starting with 3.5.2, unable to download files if connect via socks proxy

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: andyk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1

In the recent releases, I'm unable to donwload files. FF is configured to use socks proxy. Other programs download via the same proxy no problem.
In earlier releases, download worked on the same setup.

Reproducible: Always

Steps to Reproduce:
1. Configure FF to use a socks 4/5 proxy
2. If using socks 4, configure to request dns through socks
3. try to donwload any file
Actual Results:  
the file is "downloaded" - appears in the download folder with zero length. 
The file in download query appears as "cancelled"

Expected Results:  
file is donwloaded normally
This works for me with Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110109
Firefox/4.0b9pre SeaMonkey/2.1b2pre and a socks proxy.

Is this till a problem wit recent Firefox releases ?
(Reporter)

Comment 2

7 years ago
I don't use the feature no more, so let's close it as fixed.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
thanks for your response and sorry that we couldn't investigate this earlier. A socks proxy is a very special setup
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.