Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Igor Bukanov, Assigned: Igor Bukanov)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta5-fixed, blocking1.9.1 .6+, status1.9.1 .6-fixed)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
In the patch for bug 524121 I regressed date_setDate so it no longer sets the vp out parameter to NaN when argc == 0. The following test case explicitly checks for that:

function check_nan(x)
{
    if (typeof x == "number" && isNaN(x))
        return;
    throw Error("The result is not NaN: "+uneval(x));
}

var d = new Date();
check_nan(d.setTime());         
check_nan(d.setYear());         
check_nan(d.setFullYear());     
check_nan(d.setUTCFullYear());  
check_nan(d.setMonth());        
check_nan(d.setUTCMonth());     
check_nan(d.setDate());         
check_nan(d.setUTCDate());      
check_nan(d.setHours());        
check_nan(d.setUTCHours());     
check_nan(d.setMinutes());      
check_nan(d.setUTCMinutes());   
check_nan(d.setSeconds());      
check_nan(d.setUTCSeconds());   
check_nan(d.setMilliseconds()); 
check_nan(d.setUTCMilliseconds());
(Assignee)

Comment 1

8 years ago
The bug is a regression from a bug that is 1.9.2 blocker.
Severity: critical → normal
Flags: blocking1.9.2?
(Assignee)

Comment 2

8 years ago
Created attachment 410879 [details] [diff] [review]
fixing the typo

This fixes the regression that I did when refactored SetDateToNan logic.
Attachment #410879 - Flags: review?(brendan)
Attachment #410879 - Flags: review?(brendan) → review+
(Assignee)

Comment 3

8 years ago
https://hg.mozilla.org/tracemonkey/rev/3428c42d7116
Whiteboard: fixed-in-tracemonkey

Updated

8 years ago
Flags: blocking1.9.2? → blocking1.9.2+
(Assignee)

Comment 4

8 years ago
The issue is fixed on 1.9.1 as the back ported patch for the bug 524121 includes this fix.
status1.9.1: wanted → .6-fixed

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/3428c42d7116
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/a13325026f28
status1.9.2: --- → final-fixed
These bugs landed after b4 was cut. Moving flag out.
status1.9.2: beta4-fixed → final-fixed
You need to log in before you can comment on or make changes to this bug.