sporadic timeout in chrome/dom/tests/mochitest/chrome/test_focus.xul

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: dholbert, Assigned: enndeakin)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257538837.1257541324.3735.gz
Linux mozilla-central opt test everythingelse on 2009/11/06 12:20:37

{
6280 INFO TEST-PASS | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | focus method in second window
6281 INFO TEST-PASS | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | modal activeWindow
6282 INFO TEST-PASS | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | modal focusedElement
6283 INFO TEST-PASS | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | before wait for focus -- loaded: complete active window: ([object ChromeWindow]) chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/focus_window2.xul focused window: ([object ChromeWindow]) chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/focus_window2.xul desired window: ([object ChromeWindow]) chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/window_focus.xul docshell visible: true
6284 INFO TEST-PASS | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | must wait for focus
6285 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
}
(Reporter)

Updated

10 years ago
Depends on: 178324
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258025153.1258027718.23276.gz
Linux mozilla-central opt test everythingelse on 2009/11/12 03:25:53
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258027139.1258030796.29711.gz#err0
Linux mozilla-central opt test everythingelse on 2009/11/12 03:58:59
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258072599.1258076845.7806.gz
Linux mozilla-central opt test everythingelse on 2009/11/12 16:36:39  
6285 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258436602.1258439833.31365.gz
Linux mozilla-central opt test everythingelse on 2009/11/16 21:43:22
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260587007.1260590317.17051.gz
Linux mozilla-central opt test everythingelse on 2009/12/11 19:03:27
s: moz2-linux-slave21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260733977.1260737691.19816.gz
Linux mozilla-central opt test everythingelse on 2009/12/13 11:52:57
s: moz2-linux-slave21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261085810.1261090806.24119.gz
Linux mozilla-central opt test everythingelse on 2009/12/17 13:36:50
s: moz2-linux-slave21
(Reporter)

Comment 9

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261103482.1261107153.11834.gz
Linux mozilla-central opt test everythingelse on 2009/12/17 18:31:22
s: moz2-linux-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261178265.1261182386.14448.gz
Linux mozilla-central opt test everythingelse on 2009/12/18 15:17:45
s: moz2-linux-slave28
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261435761.1261441234.13867.gz
Linux mozilla-central opt test everythingelse on 2009/12/21 14:49:21
s: moz2-linux-slave23
what's the difference between this bug and bug 498799?
That bug was us being just like users, grabbing onto a single symptom like "the window goes blank" or "test_focus.xul times out" and deciding that any bug which mentions our symptom is the bug we're seeing. This bug is about having absolutely nothing other than the single symptom "test_focus.xul times out without any test error preceeding it."
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262261087.1262264177.28850.gz
Linux mozilla-central opt test everythingelse on 2009/12/31 04:04:47
s: moz2-linux-slave18
(Reporter)

Comment 16

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262757887.1262762881.5307.gz
Linux mozilla-central opt test everythingelse on 2010/01/05 22:04:47
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262950637.1262955392.23619.gz
Linux mozilla-central opt test everythingelse on 2010/01/08 03:37:17
s: moz2-linux-slave28
6326 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1263850081.1263851899.30058.gz
Linux mozilla-central opt test mochitest-other on 2010/01/18 13:28:01
s: moz2-linux-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264206949.1264208953.19436.gz
Linux mozilla-central opt test mochitest-other on 2010/01/22 16:35:49
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264464239.1264466251.18936.gz
Linux mozilla-central opt test mochitest-other on 2010/01/25 16:03:59
s: moz2-linux-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264621630.1264622859.684.gz
Linux mozilla-central opt test mochitest-other on 2010/01/27 11:47:10
s: moz2-linux-slave20
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264673402.1264674731.3756.gz
Linux mozilla-central opt test mochitest-other on 2010/01/28 02:10:02
s: moz2-linux-slave26
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264694109.1264695203.29725.gz
Linux mozilla-central opt test mochitest-other on 2010/01/28 07:55:09
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264759340.1264760363.25298.gz
Linux mozilla-central opt test mochitest-other on 2010/01/29 02:02:20
s: moz2-linux-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264875633.1264877082.14406.gz
Linux mozilla-central opt test mochitest-other on 2010/01/30 10:20:33
s: moz2-linux-slave28
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265311591.1265313155.9010.gz
Linux mozilla-central opt test mochitest-other on 2010/02/04 11:26:31
s: moz2-linux-slave28
6459 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265600375.1265601907.10373.gz
Linux mozilla-central opt test mochitest-other on 2010/02/07 19:39:35
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266443048.1266444571.21266.gz&fulltext=1
Linux mozilla-central opt test mochitest-other [testfailed] Started 13:44, finished 14:10
s: moz2-linux-slave186459 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_524745.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_524745.js | Found an unexpected browser window at the end of test run
PROCESS-CRASH | automation.py | application crashed (minidump found)
Thread 1 (crashed)
PROCESS-CRASH | automation.py | application crashed (minidump found)
Thread 1 (crashed)
PROCESS-CRASH | automation.py | application crashed (minidump found)
Thread 1 (crashed)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267370165.1267371365.18356.gz
Linux mozilla-central opt test mochitest-other on 2010/02/28 07:16:05
s: moz2-linux-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267474059.1267476253.29070.gz
Linux mozilla-central opt test mochitest-other on 2010/03/01 12:07:39
s: moz2-linux-slave21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267618797.1267621208.1960.gz
Linux mozilla-central opt test mochitest-other on 2010/03/03 04:19:57
s: moz2-linux-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267798513.1267800176.3080.gz
Linux mozilla-central opt test mochitest-other on 2010/03/05 06:15:13
s: moz2-linux-slave21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267973252.1267974843.19540.gz
Linux mozilla-central opt test mochitest-other on 2010/03/07 06:47:32
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268130481.1268132056.25385.gz 
Linux mozilla-central opt test mochitest-other on 2010/03/09 02:28:01
s: moz2-linux-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268234961.1268236682.18525.gz
Linux mozilla-central opt test mochitest-other on 2010/03/10 07:29:21
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268517332.1268519258.12373.gz
Linux mozilla-central opt test mochitest-other on 2010/03/13 13:55:32
s: moz2-linux-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268600601.1268602331.14684.gz
Linux mozilla-central opt test mochitest-other on 2010/03/14 14:03:21
s: moz2-linux-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268791031.1268792722.18540.gz
Linux mozilla-central opt test mochitest-other on 2010/03/16 18:57:11
s: moz2-linux-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268827531.1268828892.23637.gz
Linux mozilla-central opt test mochitest-other on 2010/03/17 05:05:31
s: moz2-linux-slave27
(Reporter)

Comment 46

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268885930.1268887254.32693.gz
Linux mozilla-central opt test mochitest-other on 2010/03/17 21:18:50
s: moz2-linux-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269309268.1269310592.28597.gz
Linux mozilla-central opt test mochitest-other on 2010/03/22 18:54:28
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273651302.1273653690.31125.gz
s: talos-r3-fed64-009
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2010/05/12 01:01:42 
6484 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273664476.1273665702.7461.gz
s: talos-r3-fed64-003
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2010/05/12 04:41:16
6484 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273648598.1273649788.12380.gz
s: talos-r3-fed-007
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2010/05/12 00:16:38  
6484 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Adding Enn.  Neil, can you take a look here?  It's getting to a pretty bad orange, and since it's XUL focus I was hoping you could help us figure out what's going on, maybe even fix it!

Thanks!
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273919261.1273920451.29568.gz
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2010/05/15 03:27:41
s: talos-r3-fed-009
6484 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/dom/tests/mochitest/chrome/test_focus.xul | Test timed out.
Assigning to Neil for investigation, since he was last to play around in focus code.
Assignee: nobody → enndeakin
Based on when this started, I think the most likely culprits for the regression causing an increase in frequency are:
http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=6a779c75c7bf
http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=229473c36099
(I think the first is significantly more likely.)

Ehsan, does it seem like your changes could have caused this?
I was curious, especially because my changes were related to focus behavior on text controls, so I took a deeper look.  This test is a nightmare to read (and I think we need to split it into many smaller tests), so the following could be wrong, but I think that the last check executed in this test is this one:

<http://mxr.mozilla.org/mozilla-central/source/dom/tests/mochitest/chrome/window_focus.xul#1099>

And I can't figure out what should happen next (after the following window.open call).  I tried to walk my way back in what the test executes prior to timing out, and I didn't see anything related to text controls, so at this point I don't think that my patches regressed anything about this test, although it is possible that they have made some other hidden focus bug happen more frequently.
Comment hidden (Legacy TBPL/Treeherder Robot)
(Assignee)

Comment 81

9 years ago
I changed the test to use waitForFocus for the frameset window:
http://hg.mozilla.org/mozilla-central/rev/067e44b89712
(Assignee)

Comment 82

9 years ago
Not seeing this any more so marking fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Flags: in-testsuite-
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
This doesn't seem to be fixed based on recent comments and me hitting it just now
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
Ben, I think it disappeared from m-c, hence the closing of the bug.  All subsequent occurrences have been on 1.9.2, unsurprisingly.
Ah, ok.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.