Localized Russian Firefox crashes after auto-update [@nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ]

RESOLVED WONTFIX

Status

()

P3
critical
RESOLVED WONTFIX
9 years ago
2 months ago

People

(Reporter: vadimrapp, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rare][necko-backlog], crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

I have Firefox / Russian installed on English-US system. Firefox is configured for auto-update. Whenever auto-update occurs, then firefox begins to crash on subsequent work. It's always fixed by manual installing new new version of Firefox Russian. This happened already for several recent auto-updates.

I allowed it to submit crash report several times.

Reproducible: Always

Steps to Reproduce:
1. have Firefox / localized Russian
2. configure for auto-update
3. when auto-update occurs, then firefox will begin to crash.
4. download new Russian Firefox from http://download.mozilla.org/?product=firefox-3.5.5&os=win&lang=ru and install; no more crash.
Can you please provide a stacktrace? https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Keywords: crash
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
probably only when there will be next autoupdate. But the crash report was sent successfully, and even more than once, can't you retrieve it?
Yeah, it was sent, but I have no way of knowing which, out of the thousands of stack traces we have, is yours. Please go to about:crashes, and give the id, per the instructions in the link I gave you.

Updated

9 years ago
Summary: Localized Russian Firefox crashes after auto-update → Localized Russian Firefox crashes after auto-update [@nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ]

Comment 5

9 years ago
Signature	nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry()
UUID	3ea3ea6c-6cdf-44ff-a463-215d42091106
Time 	2009-11-06 16:41:36.11787
Uptime	16
Last Crash	23 seconds before submission
Product	Firefox
Version	3.5.5
Build ID	20091102152451
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	AuthenticAMD family 6 model 6 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x1594cab
User Comments	russian firefox always crashes after auto-update
Processor Notes 	
Related Bugs

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry 	netwerk/protocol/http/src/nsHttpConnectionMgr.h:157
1 	xul.dll 	nsHttpConnectionMgr::nsConnectionEntry::`scalar deleting destructor' 	
2 	xul.dll 	nsHttpConnectionMgr::PruneDeadConnectionsCB 	netwerk/protocol/http/src/nsHttpConnectionMgr.cpp:362
3 	xul.dll 	hashEnumerate 	xpcom/ds/nsHashtable.cpp:130
4 	xul.dll 	PL_DHashTableEnumerate 	obj-firefox/xpcom/build/pldhash.c:735
5 	xul.dll 	nsHashtable::Enumerate 	xpcom/ds/nsHashtable.cpp:316
6 	xul.dll 	xul.dll@0x2c078e 	
7 	xul.dll 	nsHttpConnectionMgr::nsConnEvent::Run 	netwerk/protocol/http/src/nsHttpConnectionMgr.h:247
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:521
9 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:236
10 	xul.dll 	nsSocketTransportService::Run 	netwerk/base/src/nsSocketTransportService2.cpp:581
11 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:521
12 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:254
13 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
14 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
15 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:348
16 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:326
17 	kernel32.dll 	BaseThreadStart

Updated

9 years ago
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: 3.5 Branch → 1.9.1 Branch
(Assignee)

Updated

8 years ago
Crash Signature: [@nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ]

Comment 6

7 years ago
Vadim, 
Do you still see this crash when using current versions? 

only 6 crashes in 2 months for all releases

only the stacks of bp-d96f6d62-311e-4eeb-94af-52bc02120102 and bp-8c2d3f31-df2d-4a49-89f6-f31ca2111225 come close to matching Vadim's
Whiteboard: [rare]

Comment 7

6 years ago
still rare. three Firefox 18 crashes in one month
bp-88041ce3-deb6-4039-88aa-fd9562130114
Status: UNCONFIRMED → NEW
Crash Signature: [@nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ] → [@ nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ]
Ever confirmed: true

Updated

3 years ago
Crash Signature: [@ nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ] → [@ nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry() ] [@ nsHttpConnectionMgr::nsConnectionEntry::~nsConnectionEntry ]
Whiteboard: [rare] → [rare][necko-backlog]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.