crash when clicking on "Continue" on readmandarin.com (GIF images, GoogleAds) due to Flash Plugin 10.0.32.18

RESOLVED INCOMPLETE

Status

External Software Affecting Firefox
Flash (Adobe)
--
major
RESOLVED INCOMPLETE
8 years ago
2 years ago

People

(Reporter: Fabio Zanini, Unassigned)

Tracking

({crash, flashplayer, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091106 Shiretoko/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091106 Shiretoko/3.5.5

Readmandarin.com uses both GIF images and GoogleAds, which seem to interfere with FF.

Reproducible: Always

Steps to Reproduce:
1.Go to www.readmandarin.com/learn.htm
2.Guess a charachter and its pronunciation
3.Click on "Continue"

Actual Results:  
Firefox crashes.

Expected Results:  
Display new character page, that is:
- new GIF image
- new GoogleAd
- new text hyperlinks
Please provide a crash ID from about:crashes.
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

8 years ago
Well, I firstly tried safemode deactivating my addons, which are the following:

- AdBlock Plus (ads allowed on readmandarin.com)
- Download Manager Tweak
- Foxy Proxy (not active)

It worked like a charm. After reactivating the addons, it continues (for now) to work as expected.

Conclusion: strange as it may seem (yesterday always crashing and today never), the bug is gone. I close the report. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
I have some (bad) news. Today it was working, but only because the safe-mode disabled all plugins. Now I tested it thoroughly and the fault is of the Adobe Shockwave Flash plugin 10.0.32.18.

That is:

- without the plugin, everything is working fine;
- with the plugin, firefox crashes.

Should I try to get a backtrace or should I report it to Adobe or both?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
The safemode doesn't disable Plugins (AFAIK), only addons, themes and the Javascript JIT compiler
(Reporter)

Comment 5

8 years ago
Well, here it disabled all of it, but this is not the point. I run FF inside gdb and got the following message:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff28104f0 in g_type_check_instance_cast () from /usr/lib/libgobject-2.0.so.0

Can this help you?
(Reporter)

Updated

8 years ago
Keywords: crash, flashplayer
Summary: crash when clicking on "Continue" on readmandarin.com (GIF images, GoogleAds) → crash when clicking on "Continue" on readmandarin.com (GIF images, GoogleAds) due to Flash Plugin 10.0.32.18

Comment 6

8 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report#Linux
Component: General → Flash (Adobe)
Keywords: stackwanted
Product: Firefox → Plugins
QA Contact: general → adobe-flash
Version: unspecified → 10.x

Comment 7

2 years ago
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago2 years ago
Resolution: --- → INCOMPLETE

Comment 8

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.