"Stop script" button in Unresponsive script dialog should stop all scripts

RESOLVED DUPLICATE of bug 331658

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 331658
9 years ago
9 years ago

People

(Reporter: Jordan Osete, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1

The "Stop script" button in the unresponsive script dialog only stops the current script. If there is for example a timeout or interval waiting, it will still be executed. This can create situations where you have to kill the browser process (just like the infinite alerts https://bugzilla.mozilla.org/show_bug.cgi?id=416071 ).

Reproducible: Always

Steps to Reproduce:
1. Load the attachment
2 [review]. choose how many times. 3 is annoying enough and demonstrates the bug
2. click the "crash my browser"
Actual Results:  
The unresponsive script dialog will pop up, then even if you click "stop script", it will reappear again after a while. The browser is completely unresponsive, and you have no way to escape this.

Expected Results:  
Once "stop script" has been clicked, every script should effectively have been stoped, and the browser becomes responsive again.
(Reporter)

Comment 1

9 years ago
Created attachment 410962 [details]
Testcase. Click on the "Crash my browser" button to see the effect.
Is this a duplicate of Bug 331658, Jordan?
(Reporter)

Comment 3

9 years ago
Yes, somehow.
Sorry I made a quick search before submitting the bug, but did not find it.

However, there may be other things that need to be canceled than just timeouts.
For example event handlers. A malicious / buggy page can restart the endless loop onmouseover, and most user will just click the "stop script" button again and again, not understanding that when the unresponsive dialog disappears, their pointer automatically generates one and re-triggers the loop.

Also, this must be done for every page in the given tab (those in subframes / iframes for example), and also for web workers.

I cannot think of something else for now.
Component: General → DOM: Core & HTML
Depends on: 331658
OS: Linux → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Version: unspecified → Trunk

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 331658
You need to log in before you can comment on or make changes to this bug.