Firefox remembers a capitalized username and can't be overridden

RESOLVED DUPLICATE of bug 499649

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 499649
8 years ago
8 years ago

People

(Reporter: Pietro Battiston, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.1.4) Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.1.4) Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4

First the simple example: take a site, on which you have an account "John" and the password remembered.

OK; so now you have a _new_ account, "john". You want to login. In the login form you write "john", but Firefox immediately replaces it with "John". It's just impossible to login with the lowercase username. The only solution is to delete the password.

Now, add to this that - possibly on badly crafted sites - Firefox suggests username-password pairs that _do not_ pertain to this site. So it is sufficient that in _some_ site you registered as "John", and now not only registering in some other as "john" may make you face the problem, but if you want to solve you must understand, among the dozens of password for user "John" you registered, which is the one that is giving the problem.

Reproducible: Always

Steps to Reproduce:
See above.
(Reporter)

Comment 1

8 years ago
By the way: this didn't happen before upgrading to Firefox 3.5.4 (before, I was using 3.0).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499649
You need to log in before you can comment on or make changes to this bug.