Last Comment Bug 527253 - Icon for page context or menu entry isn't displayed
: Icon for page context or menu entry isn't displayed
Status: RESOLVED INVALID
:
Product: Mozilla Labs
Classification: Other
Component: Jetpack Prototype (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-07 12:34 PST by Polyfragmentiert
Modified: 2009-11-08 03:03 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Polyfragmentiert 2009-11-07 12:34:48 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.4) Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4) Gecko/20091028 Ubuntu/9.10 (karmic) Firefox/3.5.4

I am following Aza's video of the new 0.6 features. An available png icon (I checked the URL, of course) is not displayed on Ubuntu Karmic here. The code is:

jetpack.future.import("menu");
jetpack.future.import("selection");

jetpack.menu.context.page.add({
  label: "Translate!",
  icon: "http://dl.dropbox.com/u/794526/jetpacks/dictcc_favicon.png",

  command: function(){
    jetpack.notifications.show(jetpack.selection.text);
  }
});

Reproducible: Always

Steps to Reproduce:
1.Open about:jetpack
2.Paste the code and apply it via the textlink "try out this code" below the embedded editor
3. See the page context menu entry without the icon
Actual Results:  
No icon displayed

Expected Results:  
Referenced icon displayed before the context menu entry
Comment 1 Polyfragmentiert 2009-11-07 16:13:07 PST
Something I forgot before: I'd tried using an .ico file before resorting to the .png, didn't work either. Assigning and diplaying an .ico for a slidebar does work.
Comment 2 Drew Willcoxon :adw 2009-11-08 01:00:51 PST
This is most likely due to Gnome, which doesn't show menuitem icons by default except for page favicons.  Open up a terminal, run this command, and restart Firefox:

gconftool-2 --type bool --set /desktop/gnome/interface/menus_have_icons true

Does that work?
Comment 3 Polyfragmentiert 2009-11-08 03:03:33 PST
Thanks Drew,

that helped. Closing this bug then.

Note You need to log in before you can comment on or make changes to this bug.