Closed Bug 52727 Opened 21 years ago Closed 20 years ago

when searching a frame, Search menu item should be Find in Active Frame

Categories

(SeaMonkey :: UI Design, defect, P4)

defect

Tracking

(Not tracked)

VERIFIED WONTFIX
mozilla1.0

People

(Reporter: bugzilla, Assigned: bugzilla)

Details

Attachments

(1 file)

...right now it still says, Find in the Page. the backend, ie, searching within 
a frame *does* work, it's just that there's no visual indication within the 
Search menu (or which frame is active, but that's another bug :) that you're 
actually searching within a frame. (page in the frame context implies the main 
frameset, imo, rather than the active frame.)
this feature is part of communicator 4.x, too.
Keywords: 4xp
on the "give the user a indication in the UI" note, this would prolly go hand in 
hand with bug 41443 (which alas, has been minused).
This would be easy, but again the problem is the damn minused "show focus in 
frame" bug (so the user still doesn't really know what frame he's searching 
in).  Still, I guess the word change would be better than nothing.
Assignee: law → blakeross
Summary: when searching a frame, Search menu item should be Find in the Frame → when searching a frame, Search menu item should be Find in this Frame
I am going to checkin tonight to add the string "Find in this Frame" (I assume 
that's what you meant, since its counterpart is "Find in _this_ Page"?) just to 
workaround the i18n UI text freeze requirement, and we can implement this after 
beta3.
brendan, could you please review & approve this simple patch just to get the 
strings in before text freeze?  i'm afraid that law may not still be around 
tonight... 
Status: NEW → ASSIGNED
r=law
a=me

/be
Thanks.  However, when I went to sleep at 2am EST last night, the tree was still 
closed...so I clearly couldn't check this in.  Is it too late now?
"Find in this frame?"  What does "this" refer to?

IMO, should be "Find in active frame".
jesse, good point! esp since showing active frame isn't implemented --might as
well attempt to clarify in the menu... resummarizing.
Summary: when searching a frame, Search menu item should be Find in this Frame → when searching a frame, Search menu item should be Find in Active Frame
OS: Windows 98 → All
Priority: P3 → P4
Target Milestone: --- → mozilla1.0
Sorry to spoil the party, but I think we're making the user's life unnecessarily 
difficult here.

Analogy: A user shouldn't have to care that a page is composed entirely of 
Javascript, unless it is necessary to expose this technical detail -- e.g. if a 
script error occurs. Similarly, a user shouldn't have to care that a page is made 
up of frames, unless it is necessary to expose this technical detail -- e.g. for 
tabbing (so we need to show focus for frames), or printing (so we need to ask 
which frame), or saving (ditto).

In the case of finding text, the user does not need to know that the page is made 
up of frames. That's completely irrelevant to the task. A text search should 
start at the first frame, and go through the frames in order.
I agree.  Marking WONTFIX, but we need a new bug to search through frames in 
order (we currently just search the active frame).
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
i couldn't find such a bug existing, so i filed bug 63241...
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.