Tracking the progress of fixing right-clicking and middle-clicking on bookmarks and history

RESOLVED DUPLICATE of bug 500288

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 500288
8 years ago
8 years ago

People

(Reporter: d, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; sv-SE; rv:1.9.3a1pre) Gecko/20091107 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; sv-SE; rv:1.9.3a1pre) Gecko/20091107 Minefield/3.7a1pre

After seeing several people being annoyed by this, and creating bugs I thought it was time to do something about it. There are several issues, varying depending on OS, where you can't either right-click or middle-click bookmarks and history.

Mac OS X:

Bookmarks in the bookmark bar: Can be right and middle-clicked. - Correct.

Bookmark folders in bookmark bar: Can be right and middle-clicked. - Correct.

Bookmarks inside folders in the bookmark bar: Can be middle-clicked, but not right-clicked. - Issue.

Bookmarks in the bookmark menu: Can not be right-clicked, nor middle-clicked. - Issue.

Bookmark folders inside the bookmark menu: Can not be right-clicked, nor middle-clicked. - Issue.

Bookmarks inside folders in the bookmark menu: Can not be right-clicked, nor middle-clicked. - Issue.

History entries visible in history menu: Can not be right-clicked, nor middle-clicked. - Issue.

History seen when clicking the arrow besides the back and forward button: Can be middle-clicked, but not right-clicked. - Issue.

Now, I do not have have access to have a computer with Windows right now but I know that there are inconsistencies between the two, and I think that more things can generally be right and middle-clicked on Firefox for Windows.

A list like the one above for both Linux and Windows is appreciated. Right-clicking is the most effective way of removing a single bookmark quickly for me, and I would like to see this fixed as soon as possible, hopefully for Firefox 3.7. I can't imagine that it would be hard to fix, since the requested behavior already works on several places.

If you find bugs that bring up this problem on any OS, you can duplicate them to this bug.

Reproducible: Always

Comment 1

8 years ago
Please only report single issues in a bug. Having multiple issues makes it hard to correctly deal with bugs like this. For example there are a couple existing bugs that cover comment 0 Bug 300710 and bug 500228 apply.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500288
You need to log in before you can comment on or make changes to this bug.