After converting to SM 2.0, "some" mail folders are not visible - but "search messages" finds the messages

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: technobabe, Unassigned)

Tracking

({regression})

SeaMonkey 2.0 Branch
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

I have 11 mail accounts which I access via SM. One of these accounts has a very complex folder structure, with multiple folders 5 or 6 levels deep and folders that contain mail as well as additional folders. Upon converting to SM 2.0 in the usual manner, this account is "missing" some of the folders (i.e., the folders do not show up in the Mail Folders list). However, these folders do have the "plus control" in the Mail Folders List Pane to expand and show more folders - but when I click on this control, the plus changes to a minus, but no additional sub-folders are shown. Furthermore, just to confuse matters, only SOME of my folders that have sub-folders do not work - others work just fine. And the folders that fail to "open" consistently fail and those that work consistently work. This issue does NOT appear to be related to how far deep the parent folded is. But all my "missing" mail is present and accessible - because if I search for some of the "missing" mail using the "Search Messages" window, the messages come up! And, I can click on messages in the Search Messages window and get the actual message. So, the problem appears to be with the display of the indexing structure, not the mail or indexes, per se. I tried using "Rebuild Summary File" in the Folder Properties window, but that had no effect.
From the observed info, I can not tell if this is a problem with SM e-mail, or if the conversion utility did something wrong.
However, I view this as a urgent problem, because getting to my e-mail with "missing" folders is very difficult!


Reproducible: Always

Steps to Reproduce:
1. Open SM mail window
2. Scroll through the Mail Folders List Pane
3. Click on Plus Control
Actual Results:  
No change in Mail Folder List Pane, except that Plus Control change to a minus sign.

Expected Results:  
The Plus Control should change to a "minus" and the next to it should "open up" and display sub folders.


The behavior described is VERY consistent, the folders that function and malfunction are very consistent (even after closing and opening SM), but which folders malfunction appear to be random.

Comment 1

9 years ago
do you see anything in error console?
Keywords: regression
Version: unspecified → SeaMonkey 2.0 Branch
(Reporter)

Comment 2

9 years ago
The error console shows nothing when I click on the "plus control" to open and close the sub-folders list. (I tried several folders several times each, just to exercise it well.) Also, I have something new to add: In order to sort incoming mail, I created some new sub-folders in one of the folders where the sub-folders were no longer visible. I used these sub-folders several rimes over several days, and everything looked good. However, now these NEW sub-folders can not be seen! I have closed and re-opened SeaMonkey since the last time I saw the sub-folders, so I am guessing that is the event that caused the NEW sub-folders to disappear.

It is increasingly difficult to get things done with these folders "missing".
(Reporter)

Comment 3

9 years ago
Some new information:
1. Every time the mail application is opened, the state of the "plus control" WHEN THE MAIL WINDOW WAS LAST CLOSED seems to determine which folder's and subfolder's "plus control" will properly operate. If a folder's "plus control" is showing a minus when the mail window is closed, then that folder's "plus control" operates normally the next time the mail window is opened;
2. The folder select pull-down window in the mail "search messages" window is unaffected by this issue.
3. If I open the browser window *before* I open the mail window, then this problem does not appear. (I wish I'd known this several weeks ago!)

Comment 4

7 years ago
Is this still reproducible?

Updated

7 years ago
Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.