Closed Bug 527376 Opened 11 years ago Closed 11 years ago

Firefox 3.5.5 ignores baseline-shift CSS in SVG TSPAN elements

Categories

(Core :: SVG, defect)

x86_64
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 308338

People

(Reporter: will.pittenger1+mozbugzilla, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB5 (.NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB5 (.NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)

I was attempting to create a text object with a superscript <tspan>, but I found that vertical-align is ignored.  According to http://www.w3.org/1999/08/WD-SVG-19990812/text.html#propdef-vertical-align, vertical-align is valid on a tspan.

(I found that Inkscape is having problems with and baseline-shift.  Someone might want to test that.  See https://bugs.launchpad.net/inkscape/+bug/478737 for more information on Inkscape's problems.)

Reproducible: Always

Steps to Reproduce:
1. View any file that has vertical-align applied to a tspan
2.
3.
Actual Results:  
Firefox will display the tspan's text, but aligned vertically incorrectly.

Expected Results:  
With the attached sample, I should get superscript text.  With other vertical-align values, they should be obeyed.

BTW: I list x86_64 as my platform.  However, that refers to my OS, not my FF build.

I can provide a full config on request.
Summary: Firefox 3.5.5 ignores vertical-align CSS in SVG TSPAN elements → Firefox 3.5.5 ignores baseline-shift CSS in SVG TSPAN elements
I am told that vertical-align for SVG never made it to recommendation.  So I am replacing the sample.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 308338
You need to log in before you can comment on or make changes to this bug.