Closed Bug 527428 Opened 11 years ago Closed 11 years ago

A name before god @ is quotes

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 286760

People

(Reporter: yuriy, Unassigned)

Details

User-Agent:       Opera/9.80 (Windows NT 5.1; U; ru) Presto/2.2.15 Version/10.01
Build Identifier: 2.0.0.23 (20090812)

When I send a message, I see it in 'sent' folder with strange 'from' address as Name Surname <"myemail"@myserver.com>.
And reply-to is myemail@myserver.com
In account settings page I have both fields 'Email Address' and 'Reply-to Address' filled properly -- myemail@myserver.com
Why does Thunderbird makes a name in an addres quoted?
By this reason I can't send messages to some servers, they answer

    SMTP error from remote mail server after RCPT TO:<username@ukr.net>:
    host mxs.ukr.net [195.214.192.100]: 550 "myemail"@myserver.com:
    not supported mailfrom

Reproducible: Always

Steps to Reproduce:
1. Compose a message
Do you happen to have a space after one of your email addresses in account settings?
Oh, yes it is, I had a space after my email address, thanks for flash reaction :)
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
That makes it a duplicate of bug 286760 then.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 286760
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.