Crash when loading pages with WMP Videos

VERIFIED INVALID

Status

()

Firefox
General
--
major
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Djinn hache, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

First, sorry for my english, I'm spanish.
Second, I do not know if there already is another report like this. Sorry.

When I visit a web page which has a video on it, if the video format is for Internet Explorer by Micrososft, firefox crashes.

I have solved this by using IETab in some webs.

Maybe the problem is causes by this web, I can't know it.
It hapens to me at www.gameprotv.com when I try to watch some of the videogames videoreviews like this one: http://www.gameprotv.com/index.php?s=stream&id=1442
I have updated my firefox to the lastest version.

Have a nice day.

Reproducible: Always

Steps to Reproduce:
1. Visit www.gameprotv.com or any other site with this kind of videos.
2. Search for a videoreview like "Kameo"
3. http://www.gameprotv.com/index.php?s=stream&id=1442
4. Firefox crashes and must close it by Ctrl+Alt+Del command.
Actual Results:  
Still crashing

Expected Results:  
Play the video OR say any message like "this video can't be loaded with firefox due to problems with copyrigth or wathever... but not crash!
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

9 years ago
<OBJECT ID='WMPlay' width=592 height=400 classid='CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6' codebase='http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701' standby='Loading Microsoft Windows Media Player components...' type='application/x-oleobject'>

is an activeX object so I know firefox can't run this. But can may be not crash?
a) be sure that you have the latest WMP Plugin installed 
- http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx
b) if you still crash post a crash id from about:crashes 
- https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 3

9 years ago
Ops. Thank you. I should ask Google first.
But firefox shouldn't crashes, it should show a message. That's my opinion.

Again, Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
A Plugin runs in the same process as Firefox.
That means that the plugin becomes a parth of Firefox and Firefox can not survive a plugin crash.

The solution are out-of-process plugins and that is another bug and it's planned to do that in the near future.

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.