gradients on <body> with defined height are repeated

RESOLVED DUPLICATE of bug 283825

Status

()

Core
Layout: Images
RESOLVED DUPLICATE of bug 283825
8 years ago
8 years ago

People

(Reporter: Nikita Popov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091109 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091109 Minefield/3.7a1pre (.NET CLR 3.5.30729)

If I specify:

body {
    background-image: -moz-linear-gradient(blue, red);
    height: 200px;
}

the gradient will be rendered like this:
first a gradient having a height of 200px (from blue to red), as expected. But this gradient is repeated to fill the whole window, even though body has only 200px height.
If I specify background-repeat: no-repeat; everything's okay.

Is this how it should be? I don't think so. (At least I haven't found anything like this in the spec...)

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 411191 [details]
Litte example to view in browser.
(Reporter)

Comment 2

8 years ago
Created attachment 411192 [details]
And how it looks like...
(Reporter)

Updated

8 years ago
Attachment #411192 - Attachment mime type: text/html → image/png

Comment 3

8 years ago
(In reply to comment #0)
> Is this how it should be?

Yes. See bug 195933 and bug 283825 or take a look at the CSS spec:

http://www.w3.org/TR/CSS21/colors.html#background
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 283825
You need to log in before you can comment on or make changes to this bug.