Crash when closing any window

VERIFIED FIXED

Status

()

Core
XUL
P1
blocker
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Simon Fraser, Assigned: Chris Waterson)

Tracking

({smoketest})

Trunk
PowerPC
Mac System 8.5
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Current Mozilla builds crash when closing any window (browser, mail), with this 
stack:

...
  0BA2CC20    PPC  1E701298  nsWebShellWindow::Close()+0001C
  0BA2CBE0    PPC  1E708148  nsWebShellWindow::Destroy()+00318
  0BA2CB30    PPC  1E72B8D0  nsXULWindow::Destroy()+0062C
  0BA2C9D0    PPC  1E1BA470  nsWebShell::Destroy()+00038
  0BA2C990    PPC  1E1895D4  nsDocShell::Destroy()+00108
  0BA2C940    PPC  1E1756C4  nsDocShell::DestroyChildren()+000F4
  0BA2C8D0    PPC  1E1BA470  nsWebShell::Destroy()+00038
  0BA2C890    PPC  1E1895C4  nsDocShell::Destroy()+000F8
  0BA2C840    PPC  1E18A228 
nsGetInterface::nsGetInterface(nsISupports*, unsignedint)+11668
  0BA2C800    PPC  1E1A4CE0 
nsGetInterface::nsGetInterface(nsISupports*, unsignedint*)+2C120
  0BA2C7C0    PPC  1E1A4B60 
nsGetInterface::nsGetInterface(nsISupports*, unsignedint*)+2BFA0
  0BA2C780    PPC  1DCCA6D4  DocumentViewerImpl::Release()+0008C
  0BA2C740    PPC  1DCCB2DC  DocumentViewerImpl::~DocumentViewerImpl()+00808
  0BA2C650    PPC  1CC65D8C  nsViewManager2::Release()+00054
  0BA2C610    PPC  1CC5F024  nsView::Destroy()+00028
  0BA2C5D0    PPC  1CC5E920  nsView::~nsView()+000AC
  0BA2C570    PPC  1CC5F024  nsView::Destroy()+00028
  0BA2C530    PPC  1CC633D4  nsScrollPortView::~nsScrollPortView()+000DC
  0BA2C4E0    PPC  1CC5E920  nsView::~nsView()+000AC
  0BA2C480    PPC  1CC5F024  nsView::Destroy()+00028
  0BA2C440    PPC  1CC5E9DC  nsView::~nsView()+00168
  0BA2C3E0    PPC  1CC6A618  nsViewManager2::RemoveChild(nsIView*, nsIView*)+
000A4
  0BA2C390    PPC  1CC68A54  nsViewManager2::UpdateView(nsIView*,
unsigned int)+00078
  0BA2C340    PPC  1CC68D8C  nsViewManager2::UpdateView(nsIView*, const
nsRect&,unsigned int)+002E0
  0BA2C280    PPC  1CABC7A8  nsWindow::Invalidate(const nsRect&, int)+00080
  0BA2C200    PPC  1CABFD14  nsWindow::ConvertToDeviceCoordinates(int&, int&)+
0002C
  0BA2C1C0    PPC  1CABF440  nsWindow::CalcOffset(int&, int&)+000B4

The crash is in nsWindow::GetParent, because mParent is bad.

This is very like bug 3974, which pierre fixed over a year ago, so here you go, 
pierre! May the force be with you.
(Reporter)

Comment 1

18 years ago
Blocker n' all that.
Severity: normal → blocker
Keywords: dogfood, smoketest
Priority: P3 → P1
keywords for completeness
Keywords: nsbeta3, nsmac1
(Reporter)

Comment 3

18 years ago
Waterson has the fix, so gets the glory
Assignee: pierre → waterson
(Reporter)

Comment 4

18 years ago
Fixed by the patch to nsBoxToBlockAdapter.h, not keeping a pres shell ref. The 
crash was caused by leaked pres shells.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
I'm fairly certain this bug is no longer there.  I'll mark verified.  Cleaning 
up old resolved smoketest bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.