Reload button makes Apprunner crashes

VERIFIED FIXED in M5

Status

()

P1
major
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: teruko, Assigned: radha)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Tested 4-19-8 Win32 build under Winnt 4.0J and 8.51 Mac build.

Step of reproduce
1. Go to the above url
2. Click on Reload button
Apprunner will crash.

If you go to http://warp/employees/erik/tests/forms/nbsp/all-charsets/big5.cgi
and reload the page, Apprunner will crash.  I tested every cgi page, Apprunner
will crash after you reload.

This happens under Winnt and Mac.
(Reporter)

Updated

20 years ago
Priority: P3 → P2
Target Milestone: M5

Updated

20 years ago
Assignee: erik → morse

Comment 1

20 years ago
I don't think this is an international bug. Even using the ordinary iso-8859-1
page it crashes in Wallet in this morning's build:

http://warp/employees/erik/tests/forms/nbsp/all-charsets/

(click on iso-8859-1)

NTDLL! 77f76148()
NTDLL! 77f8a64f()
NTDLL! 77f7e485()
NTDLL! 77f64d10()
MSVCRT! 780013ef()
WALLETLIB! 01c554f5()
nsFormControlFrame::Reflow(nsFormControlFrame * const 0x014242c4, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x0055035d) line 312
nsLineLayout::ReflowFrame(nsIFrame * 0x014242c0, nsIFrame * * 0x0012a154,
unsigned int & 0x0055035d) line 837
nsBlockFrame::ReflowInlineFrame(nsBlockReflowState & {...}, nsLineBox *
0x01424860, nsIFrame * 0x014242c0, unsigned char * 0x0012828c) line 2875 + 23
bytes
nsBlockFrame::ReflowInlineFrames(nsBlockReflowState & {...}, nsLineBox *
0x01424860, int * 0x0012831c) line 2756 + 24 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x01424860, int
* 0x0012831c) line 1967 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1769 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x01424e04, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 1206 + 18 bytes
nsAreaFrame::Reflow(nsAreaFrame * const 0x01424e04, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 261 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x01424e00, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x01424c84, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x00000000) line 529
nsContainerFrame::ReflowChild(nsIFrame * 0x01424c80, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
nsTableRowFrame::InitialReflow(nsTableRowFrame * const 0x01424d80,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, RowReflowState & {...},
unsigned int & 0x00000000, nsTableCellFrame * 0x00000000, int 0x00000001) line
799 + 34 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x01424d84, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x00000000) line 1409 + 39 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x01424d80, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const
0x0141e600, nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
RowGroupReflowState & {...}, unsigned int & 0x00000000, nsTableRowFrame *
0x00000000, nsReflowReason eReflowReason_Initial, int 0x00000001) line 412 + 34
bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x0141e604,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0x00000000) line 958 + 39 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0141e600, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
nsTableFrame::ResizeReflowPass1(nsTableFrame * const 0x0141e120, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x00000000, nsTableRowGroupFrame * 0x00000000, nsReflowReason
eReflowReason_Initial, int 0x00000001) line 2606
nsTableFrame::Reflow(nsTableFrame * const 0x0141e124, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 2459 + 46 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0141e120, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x0141d354, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x00000000) line 995 + 37 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x0141d350, const nsRect & {...},
int 0x00000001, int 0x00000168, int 0x00000000, nsMargin & {...}, unsigned int &
0x00000000) line 227 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x0142a590, int * 0x0012b414) line 2538 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x0142a590, int
* 0x0012b414) line 1964 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1769 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x013b1f04, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000001) line 1206 + 18 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x013b1f00, const nsRect & {...},
int 0x00000001, int 0x00000000, int 0x00000001, nsMargin & {...}, unsigned int &
0x00000001) line 227 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x013b18e0, int * 0x0012d6d8) line 2538 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x013b18e0, int
* 0x0012d6d8) line 1964 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1769 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x013b1a04, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 1206 + 18 bytes
nsAreaFrame::Reflow(nsAreaFrame * const 0x013b1a04, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 261 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x013b1a00, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x013b1754, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 237
nsContainerFrame::ReflowChild(nsIFrame * 0x013b1750, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
nsScrollFrame::Reflow(nsScrollFrame * const 0x013b0a04, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 394
nsContainerFrame::ReflowChild(nsIFrame * 0x013b0a00, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 389 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x013b0824, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 434
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x0142a780,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsSize & {...},
nsIRenderingContext & {...}) line 169
PresShell::ProcessReflowCommands(PresShell * const 0x0135b890) line 1240
PresShell::ExitReflowLock(PresShell * const 0x0135b890) line 667
PresShell::ContentAppended(PresShell * const 0x0135b898, nsIDocument *
0x01412120, nsIContent * 0x013b076c, int 0x00000000) line 1744
nsDocument::ContentAppended(nsDocument * const 0x01412120, nsIContent *
0x013b076c, int 0x00000000) line 1459
nsHTMLDocument::ContentAppended(nsHTMLDocument * const 0x01412120, nsIContent *
0x013b076c, int 0x00000000) line 632
HTMLContentSink::WillInterrupt(HTMLContentSink * const 0x01417320) line 1572
CNavDTD::WillInterruptParse(CNavDTD * const 0x0135bea0) line 2905 + 27 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000) line 831
nsParser::OnDataAvailable(nsParser * const 0x01417aa4, nsIURL * 0x0141a790,
nsIInputStream * 0x0140c800, unsigned int 0x00000945) line 1033 + 17 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x0141a710,
nsIURL * 0x0141a790, nsIInputStream * 0x0140c800, unsigned int 0x00000945) line
1968 + 24 bytes
OnDataAvailableProxyEvent::HandleEvent(OnDataAvailableProxyEvent * const
0x0135bd30) line 632
StreamListenerProxyEvent::HandlePLEvent(PLEvent * 0x0135bd34) line 471 + 12
bytes
PL_HandleEvent(PLEvent * 0x0135bd34) line 476 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0129f820) line 437 + 9 bytes
_md_EventReceiverProc(void * 0x004606de, unsigned int 0x0000c0b5, unsigned int
0x00000000, long 0x0129f820) line 799 + 9 bytes
USER32! 77e71250()

Comment 2

20 years ago
teruko@netscape.com (Teruko Kobayashi) wrote:

Erik mentioned in the bug report that Apprunner crashed in Wallet. If so, are
there any ways to turn off the Wallet? I appreciate if you reply this mail.

Teruko

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME

Comment 3

20 years ago
Two comments:

First, this is not a wallet problem.  I don't see any lines in the trace
indicating a wallet crash.  If you have such a trace, please include it and file
a bug agains wallet.

Second, this works for me.  I do not get a crash.  When I went to the indicated
URL I got a page saying

   "NOT FOUND:  The request object does not exist on this server.
   The link you followed is either outdated, inaccurate,
   or the server has been instructed not to let you have it."

And pressing reload does not cause a crash.

Now I believe I can even explain the not-found message.  Since we don't have
dialogs implemented yet, the authentication dialog is currently coming up in the
console window.  In this window you have to enter your user name and password.
However, there were complaints about having this so I was asked to not use the
dialog unless a preference were set asking for the dialog.  Therefore by default
there is no dialog and instead the routine that would have put up the dialog is
simply returning a dummy username and password.  Of course that is the wrong
username and password for this page and so you are getting an authentication
failure.  That is why "the server has been instructed not to let you have it."

So you don't want to turn anything off -- rather you want to turn the dialogs
on.  You can do that by putting the following line in your preference file by
hand:

   user_pref("wallet.useDialogs", true);

Now don't ask me where that preference file is to be put or what it is to be
called.  As of last week it was in prefs.js which belonged in
\mozilla\dist\WIN32_D.OBJ\bin.  But that's been changed this week and I don't
know where or what the new prefs file is.

In any event, the bug report is either works-for-me because I am not
seeing the crash being reported, or it is invalid because the not-found message
is appropriate under the circumstances (as I explained).  So I flipped a coin
and decided to close it out as works-for-me.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 4

20 years ago
I am sorry I made typo in URL, I corrected.  I tested this in 4-26-08 build. It still crashes.
(Reporter)

Updated

20 years ago
Component: Internationalization → Autofill

Updated

20 years ago
Assignee: morse → karnaze
Status: REOPENED → NEW
Component: Autofill → Internationalization

Comment 5

20 years ago
OK, with this corrected URL I see the crash.  But it is not a wallet problem and
the stack trace is not at all what was indicated by Erik above.  It looks like a
layout problem.  Assigning to karnaze

Here's my stack strace

nsPresContext::StopAllLoadImagesFor(nsPresContext * const 0x0255cc70, nsIFrame *
0x00000000) line 797 + 7 bytes
nsHTMLImageLoader::StopAllLoadImages(nsIPresContext * 0x0255cc70) line 103
nsImageFrame::DeleteFrame(nsImageFrame * const 0x02561e60, nsIPresContext &
{...}) line 90
nsLineBox::DeleteLineList(nsIPresContext & {...}, nsLineBox * 0x02562120) line
158
nsBlockFrame::DeleteFrame(nsBlockFrame * const 0x02561cf0, nsIPresContext &
{...}) line 800 + 16 bytes
nsAreaFrame::DeleteFrame(nsAreaFrame * const 0x02561cf0, nsIPresContext & {...})
line 102
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x02561bf0,
nsIPresContext & {...}) line 82
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x025618a0,
nsIPresContext & {...}) line 82
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x0255d460,
nsIPresContext & {...}) line 82
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x01207bf0,
nsIPresContext & {...}) line 82
nsTableFrame::DeleteFrame(nsTableFrame * const 0x01207bf0, nsIPresContext &
{...}) line 350
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x01206440,
nsIPresContext & {...}) line 82
nsLineBox::DeleteLineList(nsIPresContext & {...}, nsLineBox * 0x02568610) line
158
nsBlockFrame::DeleteFrame(nsBlockFrame * const 0x011fe120, nsIPresContext &
{...}) line 800 + 16 bytes
nsLineBox::DeleteLineList(nsIPresContext & {...}, nsLineBox * 0x011fe1f0) line
158
nsBlockFrame::DeleteFrame(nsBlockFrame * const 0x011fd8a0, nsIPresContext &
{...}) line 800 + 16 bytes
nsAreaFrame::DeleteFrame(nsAreaFrame * const 0x011fd8a0, nsIPresContext & {...})
line 102
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x011fd690,
nsIPresContext & {...}) line 82
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x025084a0,
nsIPresContext & {...}) line 82
nsFrameList::DeleteFrames(nsIPresContext & {...}) line 29
nsContainerFrame::DeleteFrame(nsContainerFrame * const 0x02486aa0,
nsIPresContext & {...}) line 82
ViewportFrame::DeleteFrame(ViewportFrame * const 0x02486aa0, nsIPresContext &
{...}) line 112
PresShell::~PresShell() line 543
PresShell::`scalar deleting destructor'(unsigned int 1) + 15 bytes
PresShell::Release(PresShell * const 0x011f37f0) line 483 + 34 bytes
DocumentViewerImpl::~DocumentViewerImpl() line 216 + 18 bytes
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x0255bc20) line 153 + 99
bytes
nsWebShell::Embed(nsWebShell * const 0x011d5e20, nsIContentViewer * 0x025755e0,
char * 0x02553b40, nsISupports * 0x00000000) line 711 + 27 bytes
nsDocumentBindInfo::OnStartBinding(nsDocumentBindInfo * const 0x025536b0, nsIURL
* 0x02553200, char * 0x02575330) line 1898 + 36 bytes
OnStartBindingProxyEvent::HandleEvent(OnStartBindingProxyEvent * const
0x025752e0) line 506
StreamListenerProxyEvent::HandlePLEvent(PLEvent * 0x025752e4) line 471 + 12
bytes
PL_HandleEvent(PLEvent * 0x025752e4) line 476 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ee1c00) line 437 + 9 bytes
_md_EventReceiverProc(void * 0x063a08e6, unsigned int 49314, unsigned int 0,
long 15604736) line 799 + 9 bytes
USER32! 77e

Comment 6

20 years ago
Generated a talkback report running 1999-04-26-08 build on US NT4:

http://cyclone/reports/incidenttemplate.CFM?reportID=1568&style=0&tc=1&cp=1&ck1=
SNub+trigger+event+time&cd1=1999%2F04%2F26&bbid=7770050
(Reporter)

Updated

20 years ago
Summary: Reloading each cgi page makes Apprunner crashes → Reloading each page makes Apprunner crashes
(Reporter)

Comment 7

20 years ago
I tested the Latin1 pages under Winnt 4.0J and Winnt 4.0US. Apprunner crashes after clicking reload button.
I do not think this is anthing to do which page you are reloading.
When you click on Back, Forward, Reload, and Stop button after you run Apprunner, Apprunner will crash.

Updated

20 years ago
Resolution: WORKSFORME → ---

Comment 8

20 years ago
Cleared WORKSFORME resolution.
Generated another talkback report running 1999-04-26-08 build on US NT4
by hitting stop button immediately after starting apprunner.exe:

http://cyclone/reports/incidenttemplate.CFM?reportID=1568&style=0&tc=2&cp=1&ck1=
SNub+trigger+event+time&cd1=1999%2F04%2F26&bbid=7773203
(Reporter)

Updated

20 years ago
Assignee: karnaze → trudelle
Summary: Reloading each page makes Apprunner crashes → Reload button makes Apprunner crashes
(Reporter)

Comment 9

20 years ago
I tested 4-19-08 Win32 and MAC build which I found the original bugs.  Clicking on Reload, Forward, Back, and Stop button does
not cause Apprunner crashs in these builds.  However, when I tested 4-26-08 Win32 and MAC build, clicking on Reload,
Forward, Back, and Stop button causes Apprunner crashes.

I reassign this to trudelle@netscape.com.

Updated

20 years ago
Assignee: trudelle → don

Comment 10

20 years ago
Today's optimized build crashes for me on NT clicking any button in that
toolbar (even just after loading the default page), but buttons in other
toolbars seem to work fine (e.g., component bar, messenger). reassigning to don

Updated

20 years ago
Assignee: don → radha

Comment 11

20 years ago
Radha, can you find out what's going on here ...

Updated

20 years ago
Priority: P2 → P1
(Reporter)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

20 years ago
This does not happen in 4-27-13 Win32 and Mac build.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

20 years ago
I verified this in Win32 , MAC, and Linux 5-3-8 build.
You need to log in before you can comment on or make changes to this bug.