Messaging in weave prefs connection is ambiguous

RESOLVED FIXED in 1.0 beta3

Status

()

P2
normal
RESOLVED FIXED
9 years ago
25 days ago

People

(Reporter: tchung, Assigned: mconnor)

Tracking

unspecified
1.0 beta3
Points:
---
Bug Flags:
blocking-weave1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 411243 [details]
Disconnected screenshot

The messaging in the weave account preferences is confusing.  It indicates the user is "connected as: <name>" when in fact they could be Disconnected at the time.  Furthermore there is no way to edit the username in that textbox, even though it gives people the perception they can edit the existing user.

** see screenshot

Repro:
1) weave 0.8
2) open prefs
3) Disconnect your sync connection.  Two problems:
-- The messaging says "Connected as <user>" despite being connected.
-- No way to edit the user textbox even though its a clickable text region

Expected:
- If disconnected, message so you're disconnected
- make the text box un-editable if it really is supposed to be that way

Updated

9 years ago
Flags: blocking-weave1.0+
Target Milestone: --- → 1.0 beta2
(Assignee)

Updated

9 years ago
Assignee: nobody → mconnor
Priority: -- → P2
(Assignee)

Comment 1

9 years ago
http://hg.mozilla.org/labs/weave/rev/62e1508dbc21
replace Connected As with Current User to remove ambiguity
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.