Discourage filter editing of deferred-from POP3 server filters

RESOLVED DUPLICATE of bug 537012

Status

--
major
RESOLVED DUPLICATE of bug 537012
9 years ago
8 years ago

People

(Reporter: rkent, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
The choice of whether to use the filters for the POP3 server, or for Local Folders, is quite confusing for users who defer incoming messages to Local Folders.

It seems to me that in virtually all cases, the correct place to put filters is on Local Folders. When they are placed there, then both incoming, manual, and after classification filters work. When placed on the POP3 server account, which is probably the user's initial instinct, then only Incoming works.

It seems to me that we could eliminate this if we simply did not by default allow the choice of the deferred-from POP3 server in cases where the filter list for that server is empty (to allow support for legacy filters). Perhaps we could allow a hidden preference to allow it to show if someone really had a good use case for that - but I can't think of any.

Updated

9 years ago
Duplicate of this bug: 546284

Comment 2

9 years ago
As Kent points out in Bug 546284, this is a common source of confusion for users. I would think this is a pretty easy fix. (I have not attempted to find any more bugs to duplicate to this)
Severity: normal → major
(Reporter)

Updated

9 years ago
Summary: Disable filter editing of deferred-from POP3 server filters → Discourage filter editing of deferred-from POP3 server filters
(Reporter)

Comment 3

9 years ago
My previous "disable" editing was too strong, but "discourage" is appropriate.

Because there are other related bugs that involve selection of filters, I believe that this bug is going to get mostly resolved by those patches. I will link to them to make the point which bugs are implementing this change in philosophy.

For the current bug, perhaps it probably makes sense to explicitly disable selection of manual context in the filter editor for deferred-from servers, as that context does not actually do anything in that case.
Depends on: 537012

Comment 4

8 years ago
bienvenu states "there are examples in the code". Wordings, etc would need UI approval.
Whiteboard: [good first bug]
(Reporter)

Comment 5

8 years ago
I changed the defaults in 3.1 so that the deferred-to filters have now been chosen as the defaults. This is probably enough discouragement, so let me mark this as a dup of that.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537012

Updated

8 years ago
Whiteboard: [good first bug]
You need to log in before you can comment on or make changes to this bug.