Firefox 3.6b1 hangs when visiting the URL

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: djc, Unassigned)

Tracking

({perf})

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
(This happens on my laptop, Snow Leopard.)
(Reporter)

Comment 1

8 years ago
Actually, I misremembered. It didn't crash, it just stopped responding and I had to kill it (I sent one report to Apple, no Firefox crash reporter).
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091110 Minefield/3.7a1pre

It hangs indeed with all Firefox versions I tried. Also with IE8, Google Chrome and Opera. Maybe sending with the wrong content type?
(Reporter)

Comment 3

8 years ago
Well, yeah, it's trying to send the source of a 9.2M file PDF inline, which probably isn't as intended. Still, Firefox hanging seems bad.

Comment 4

8 years ago
Also, hung and then crashed my trunk nightly.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091110 Minefield/3.7a1pre
Severity: normal → critical
Keywords: hang
Summary: Firefox 3.6b1 crashes when visiting the URL → Firefox 3.6b1 hangs when visiting the URL

Comment 5

6 years ago
In Windows Task Manager it took like 500MB while hanging.
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
behaves poorly in terms of cpu and memory and stops after about 40-50seconds on fast 4GB machine, but not before firefox gobbled 800MB. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101227 Firefox/4.0b9pre

very likely a duplicate of a layout performance bug
Severity: critical → major
Keywords: hang → perf
Whiteboard: dupeme
(Reporter)

Comment 8

6 years ago
Works fine on Aurora (8.0a2).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

5 years ago
Resolution: FIXED → WORKSFORME

Updated

3 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.