Improve wording of windows registry entry for ScriptInterpreterSource

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: a.hurst, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.15) Gecko/2009101601 Firefox/3.0.15 (.NET CLR 3.5.30729)
Build Identifier: 3.4.3

In section indicated, the ambiguous wording should be altered to highlight the difference between 
HKCR\.cgi\Shell\ExecCGI\Command = "C:\Perl\bin\perl.exe -T"
which won't work, and
HKCR\.cgi\Shell\ExecCGI\Command\(Default) = "C:\Perl\bin\perl.exe -T"
which will.

Instead of 
..."the key
HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI\Command
with C:\Perl\bin\perl.exe -T as value"...

would be better 
..."the key
HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI\Command
with value (Default) = C:\Perl\bin\perl.exe -T"...

Since keys can't have values (they are 'folders'), they CONTAIN values.

Reproducible: Always

Comment 1

9 years ago
Hum, this seems pretty clear to me. We explicitly say "as value", so you cannot do it wrong, I think.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

9 years ago
I am a native English speaker, with a degree in computer science, PhD in physics (pending thesis submission), and 10+ years of registry hacking experience, and I did it wrong :)
Maybe I'm still an idiot.

Perhaps better phrased "as default value"?
Explicitly stated or not, keys can contain many values, the one which is required is the one named "(Default)".
I agree that that is unclear. However, that particular piece of documentation is rarely used, since the only correct Windows install instructions are on the Wiki instead.

Probably we should just refer to the Wiki from the docs.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Still valid with new docs.

Gerv

Comment 5

3 years ago
This has been fixed in 5.0 when rewriting the Windows documentation:

http://bugzilla.readthedocs.org/en/latest/installing/apache-windows.html
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.