Closed Bug 527685 Opened 11 years ago Closed 11 years ago

Simplify widget transparency handling

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1

People

(Reporter: mstange, Assigned: mstange)

References

Details

Attachments

(1 file)

Attached patch v1Splinter Review
Contrary to popular belief Gecko can handle transparent child widgets just fine. Our Cocoa widget transparency setup tries to ensure that only the top level ChildView is transparent, but that's an unnecessary limitation.
Removing that limitation makes the code a lot simpler.
Attachment #411423 - Flags: review?(joshmoz)
Attachment #411423 - Flags: review?(roc)
Attachment #411423 - Flags: review?(joshmoz) → review+
http://hg.mozilla.org/mozilla-central/rev/9ce4279f72f0
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Attachment #411423 - Flags: approval1.9.2?
Duplicate of this bug: 533877
Attachment #411423 - Flags: approval1.9.2?
You need to log in before you can comment on or make changes to this bug.