[FLOAT] Floats with different parents are overlapping

RESOLVED WORKSFORME

Status

()

P3
minor
RESOLVED WORKSFORME
20 years ago
4 years ago

People

(Reporter: dbaron, Assigned: buster)

Tracking

({css1})

Trunk
Future
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3-][rtm-] probably not hit during nsbeta2 standards compliance testing, URL)

With a maximized window, I see overlapping floats in:

Test 1 of the above URL, right side, image float (orange) on top of text float
(gray).

This *may* be related to the fix for weird behavior in bug 1605 on
http://www.w3.org/Style/CSS/Test/current/sec5525b.htm
which is now correct.  I put what I am seeing (which is correct!) at:
http://www.fas.harvard.edu/~dbaron/tests/nglayout/5525b_correct
The difference results from the 4th line of text in the 3rd paragraph within
the table.  The position of those images is very strange because of the
combination of overlap and negative margins, so the behavior should be
different at different window sizes, but what is shown there covers the two
alternatives.  (Note that the difference is that within the table, the *outer*
top (with negative margin) of the second float is below the first float,
whereas the first time it is not.)

You should watch that page for regressions if you work on this bug, I think.

Updated

20 years ago
Assignee: troy → kipp

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Priority: P3 → P2

Updated

20 years ago
Target Milestone: M9 → M15
Summary: Floats with different parents are overlapping → {css1} Floats with different parents are overlapping

Updated

20 years ago
QA Contact: 4144 → 4110

Comment 1

20 years ago
With current builds (at least with my current tree), the floaters do not overlap
each other. However, the text in many of the test cases do overlap the floaters.
I assume that this is bad and needs to be fixed.
Assumtion correct.  However, I'm still seeing the overlap too.
*** Bug 7627 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
*** Bug 6097 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Target Milestone: M17 → M16

Comment 5

19 years ago
Fixing this bug is too dangerous to fix in the beta; moving to just past the
beta.
I think this is mostly fixed, except for one really minor problem: the text
"This is short" is incorrectly indented within the table.

Updated

19 years ago
Assignee: kipp → troy
Status: ASSIGNED → NEW

Comment 7

19 years ago
Updating to default Layout Assignee...kipp no longer with us :-(

Updated

19 years ago
Assignee: troy → kipp

Comment 8

19 years ago
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
(Assignee)

Updated

19 years ago
Summary: {css1} Floats with different parents are overlapping → {css1} [FLOAT] Floats with different parents are overlapping
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...

Comment 10

19 years ago
Is this bug still a problem? I can't see any using the 1/21 build.

Updated

19 years ago
Summary: {css1} [FLOAT] Floats with different parents are overlapping → [FLOAT] Floats with different parents are overlapping
(Assignee)

Comment 11

19 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
I think this bug is fixed too...
(Assignee)

Comment 13

19 years ago
Important to fix, but low priority for beta2.  Moving to M17.
Status: NEW → ASSIGNED
Target Milestone: M16 → M17
Nominating nsbeta2,nsbeta3,rtm. Recc. nsbeta2+, falling through to nsbeta3+ and 
rtm+ if necessary. This is a W3C CSS1 Official Test Suite compliance bug.
Keywords: nsbeta2, nsbeta3, rtm
Sorry, to clarify: this is not an nsbeta2 stopper, but I'd permit checking in 
prior to nsbeta2 if we have a fix. Recc. nsbeta2+[some lenient date-], falling 
through to nsbeta3+ hard stop if not fixed during nsbeta2. This is a W3C CSS1 
Official Test Suite compliance bug.

Comment 16

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [nsbeta2-]

Updated

18 years ago
Keywords: verifyme
As per meeting with ChrisD today, taking QA.
Keywords: correctness
QA Contact: chrisd → py8ieh=bugzilla
Whiteboard: [nsbeta2-] → [nsbeta2-] hit during nsbeta2 standards compliance testing

Comment 18

18 years ago
Denying for beta3: bigger problems to solve in very limited time - sorry.
Whiteboard: [nsbeta2-] hit during nsbeta2 standards compliance testing → [nsbeta2-] [nsbeta3-] hit during nsbeta2 standards compliance testing
David: I'm having difficulty working out what the problem is here. Could you
clarify your bug report?

It doesn't help that the W3C test suite is triggering quirks mode...	
Assignee: buster → dbaron
Severity: normal → minor
Status: ASSIGNED → NEW
Target Milestone: M17 → Future
(...I just realised that I must have understood this bug at some point, since
I thought I had run into it. Ahem.)
Keywords: qawanted
Whiteboard: [nsbeta2-] [nsbeta3-] hit during nsbeta2 standards compliance testing → [nsbeta2-] [nsbeta3-] hit during nsbeta2 standards compliance testing (py8ieh:reexamine)
This URL in this bug was the old version of sec414.  URL changed accordingly.

I still don't see the bug.  Ian, if you agree, please mark FIXED.
Marking WORKSFORME. The only bug I see is the float after "This is short." is 
too low, but that seems difficult to me (doing it right requires a reflow of 
previously flowed content). And that problem is definitely [nsbeta3-]. And its
another bug anyway.

I'm rather confused about why I marked this bug 'hit during nsbeta2 standards 
compliance testing'. I must have been under the influence of the XBL team's,
ah, stimulants or something.
Assignee: dbaron → buster
QA Contact: py8ieh=bugzilla → dbaron
Whiteboard: [nsbeta2-] [nsbeta3-] hit during nsbeta2 standards compliance testing (py8ieh:reexamine) → [nsbeta2-] [nsbeta3-] probably not hit during nsbeta2 standards compliance testing (py8ieh:reexamine)

Comment 23

18 years ago
Ian...did you mean to mark this worksforme?  Setting to [rtm-]
Whiteboard: [nsbeta2-] [nsbeta3-] probably not hit during nsbeta2 standards compliance testing (py8ieh:reexamine) → [nsbeta2-][nsbeta3-][rtm-] probably not hit during nsbeta2 standards compliance testing (py8ieh:reexamine)
Er, yes. Geez, what is wrong with me on this bug!
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Whiteboard: [nsbeta2-][nsbeta3-][rtm-] probably not hit during nsbeta2 standards compliance testing (py8ieh:reexamine) → [nsbeta2-][nsbeta3-][rtm-] probably not hit during nsbeta2 standards compliance testing
Keywords: qawanted, verifyme
You need to log in before you can comment on or make changes to this bug.