Crash after responding to 'cookie' or 'image' prompt

VERIFIED DUPLICATE of bug 57188

Status

()

Core
Networking: Cookies
P1
critical
VERIFIED DUPLICATE of bug 57188
18 years ago
18 years ago

People

(Reporter: Andrew McMillan, Assigned: Stephen P. Morse)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have Mozilla set to query me before accepting either a cookie or an image and
I am having a regular problem with it crashing after I click on the "Yes" or
"No" button after such a prompt.

Here's the console log after such a crash:
Document about:blank loaded successfully
Document http://www.linuxplanet.com/linuxplanet/interviews/2295/2/ loaded
successfully
Document http://www.linuxplanet.com/linuxplanet/interviews/2295/3/ loaded
successfully
Error loading URL http://slashdot.org/: 80004004
Document http://www.linuxplanet.com/linuxplanet/interviews/2295/4/ loaded
successfully
->>>>>>>>>>>>>> Write Clipboard to memory
we don't handle eBorderStyle_close yet... please fix me
we don't handle eBorderStyle_close yet... please fix me
/home/andrew/bin/mozilla: line 8:  1900 Segmentation fault
$MOZILLA_FIVE_HOME/mozilla-bin $@

Note that I usually have several windows open - perhaps this is a contributing
factor.  As a result of this I have found the September nightly builds to be
generally too unstable for regular use.
Currently using: Mozilla/5.0 (X11; U; Linux 2.2.17 i586; en-US; m18) Gecko/20000914

Comment 1

18 years ago
There is a known issue with cookie management, but for now marking dup of bug
52736 where image managing is also specifically mentioned.

*** This bug has been marked as a duplicate of 52736 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
I can't reopen bug 52736 that this was marked as a duplicate of, but I am still
seeing this problem.  I have had three crashes exactly like this in the last
hour, which is way more often than usual.  What _is_ different this evening is
that I have a very busy CPU, pegged at 100% in the background.

My wife also complains that this happens to her under Windows as well, so I
don't really think it is Linux-only as the previous thread indicated.

I'm now seeing one more message in the log, after the eBorderStyle_close not
implemented:
frame error: (error "no such cursor" ())
repeated about six times.

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

18 years ago
How to duplicate this bug:
1) Enable the ask before images/cookies notification in prefs
2) Load a URL
3) Do NOT do anything in the confirm dialog (Yes/No, close, etc)
4) Switch back to the browser window and view a new URL
5) Let the document load
6) Click Yes/No on the first notification window, Mozilla will crash.

Confirming on 2000110604 WinNT Mtrunk and changing platform to all
Status: UNCONFIRMED → NEW
Component: Browser-General → Cookies
Ever confirmed: true
OS: Linux → All

Comment 4

18 years ago
over to cookies
Fabian
Severity: normal → blocker
Priority: P3 → P1
QA Contact: doronr
Hardware: PC → All
Summary: Crash after responding to 'cookie' or 'image' prompt
Target Milestone: --- → M1

Comment 5

18 years ago
repairing this bug.  It seems to have been kinda messed up in the last
transaction.  Restoring Summary, unsetting TM, lowering severity and reassigning
to default owner and QA contact 
Assignee: asa → morse
Severity: blocker → critical
QA Contact: tever
Summary: Crash after responding to 'cookie' or 'image' prompt
Target Milestone: M1 → ---
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M20
(Assignee)

Updated

18 years ago
Summary: Crash after responding to 'cookie' or 'image' prompt → [x]Crash after responding to 'cookie' or 'image' prompt
Target Milestone: M20 → ---
(Assignee)

Comment 6

18 years ago
I'm not exactly sure that I understand this.  The dialog is modal so it is not 
possible to get to step 4.  That is, once you are in the dialog, you cannot 
switch back to the browser window until you dismiss the dialog.

Please give a more detailed set of steps, including actual URL's visited and be 
more specific as to how you do step 4.
(Reporter)

Comment 7

18 years ago
What?  The dialog certainly doesn't seem modal under Linux, and I don't think it
is under Windows 95 or 98 either.

When I go to a site that has images from several locations, and maybe even
cookies from several locations, I get a whole bunch of messages prompting me if
I want to accept cookies/images from these various places.  If I don't respond
to these in the order in which they are presented, then Mozilla crashes.

Of course I almost invariably _don't_ respond to them in the correct order,
because each new one goes over the top of a previous one.  Sometimes I am
prompted twice for the same site, presumably when the parsing of the HTML
encounters a second image from there before I've responded to the first prompt.
(Assignee)

Comment 8

18 years ago
It sure is supposed to be modal.  If it's not, we have a more serious problem 
here.  cc'ing danm.

Comment 9

18 years ago
  There's always the potential for a modal window to use the wrong parent and 
effectively not be modal. Or maybe you're using some misbehaving window manager 
which ignores the cues we're giving it? Maybe. I would hope that wouldn't be 
possible, but...
  But I just tried this and had no problems -- the alerts were modal and I was 
unable to switch URLs and start a new load while an alert was up. I'm using 
RedHat 6.2 and Enlightenment. Andrew: spill some details. OS, Window Manager, 
URL?
  (The "hail me with alerts on every image and cookie" option isn't something I 
try very often. Hopefully you have a sample website that doesn't spawn too many 
of them. Personally, I get terminally bored after about the thirtieth and kill 
the %!#%$ process. But at least the first thirty are well-behaved for me.)
(Reporter)

Comment 10

18 years ago
I'm running Linux (Debian Woody) with Sawfish for my window manager.  I have
just had a play around a bunch of websites that I wouldn't normally visit, so I
got lots of prompts for images / cookies.

Something may have changed (I got a new MTrunk build yesterday - 2000111608),
because I certainly aren't seeing the overlayed multiple prompts that I have in
the past.  With the prompt for a cookie the question seemed almost completely
modal - although I could click on the browser window and have the WM give it
focus it didn't appear to accept anything, and the cookie prompt remained in front.

The Images prompt appeared much the same, except that I was also able to bring
the browser window to the front.  I still couldn't enter in a new URL though.

Looks like something might have fixed this in passing.

Comment 11

18 years ago
That's the behaviour I'm seeing on my system. So, Eric -- what unusual thing 
about your system is allowing step 4 in your steps to reproduce?
(Assignee)

Updated

18 years ago
Summary: [x]Crash after responding to 'cookie' or 'image' prompt → Crash after responding to 'cookie' or 'image' prompt
Whiteboard: [x]

Updated

18 years ago
Keywords: crash
(Assignee)

Comment 12

18 years ago
From the last few comments in this bug report, it appears that now it is 
happening on the image-warning box only and the cookie-warning box is OK.  In 
that case, this is a dup of 57188.

*** This bug has been marked as a duplicate of 57188 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 13

18 years ago
verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

18 years ago
Whiteboard: [x]
You need to log in before you can comment on or make changes to this bug.