The default bug view has changed. See this FAQ.

Folder pane changes to smart folders if new message is opened from mail notification popup and the account that the message is for, is collapsed

RESOLVED FIXED in Thunderbird 3.1a1

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Nir, Assigned: sid0)

Tracking

Trunk
Thunderbird 3.1a1
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(blocking-thunderbird3.0 .1+, thunderbird3.0 .1-fixed)

Details

(Whiteboard: [fixed by bug 536042])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4) Gecko/20091027 Fedora/3.5.4-1.fc11 Firefox/3.5.4 XPCOMViewer/0.9a
Build Identifier: 

This bug has similar behaviour as Bug 524821 although trigger points is different. 

 

Reproducible: Always

Steps to Reproduce:
1. Set Folder View to ALL'
2. Send a message to yourself and wait for the mail notfication popup to appear.
3. When alert popup appears clicks on the message in popup.
Actual Results:  
Folder view abruptly changed to Smart Folders. 

Expected Results:  
Folder view will remain unaffected.
(Reporter)

Comment 1

8 years ago
Forget to mention that I'm using
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6pre) Gecko/20091110 Shredder/3.0pre
Version: unspecified → Trunk
Anything in Tools -> Error console when this happens ?

Does it happens in safe-mode too ?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Anything in Tools -> Error console when this happens ?

No, nothing is logged in Error console. Although as I lunched Tb from linux console, some debug/output messages are logged in there. I'll attach the log separately.

> Does it happens in safe-mode too ?

Yes it happens in safe mode also.
Today I did al little more research to find a fail-safe method to reproduce it and realized it occurs only when the account which got new message is collapsed in folder pane. If the account tree is expanded prior to get mail notification ( and clicking on it ), this issue doesn't occur.
(Reporter)

Comment 4

8 years ago
Created attachment 411713 [details]
Linux console log

This is what  got from Linux console. It entirely looks like golda related information but in case if you find anything important out of it ...
Magnus are you also seeing that ?

Comment 6

8 years ago
Yeah, i see it too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Folder pane changes to smart folders if new message is opened from mail notification popup. → Folder pane changes to smart folders if new message is opened from mail notification popup and the account that the message is for, is collapsed
Duplicate of this bug: 520330

Comment 8

8 years ago
I did see this behavior for the first time in the last RC1 and it wasn't in b4 I'm sure. Hope this can get resolved before final release, it's really annoying.
Duplicate of this bug: 529512
It happens also on Windows: changed OS related.
OS: Linux → All

Updated

7 years ago
Duplicate of this bug: 531316
right, the root cause (bug 536042) is the same as bug 524821.
Blocks: 536042
(Assignee)

Updated

7 years ago
No longer blocks: 536042
Depends on: 536042
blocking-thunderbird3.0: --- → needed

Comment 13

7 years ago
Similarly, if you are already in smart folders, and the account that the message is for is collapsed (i.e. the InBox is open at the top of the smart folders tree and you open a message into a tab, but the owning account tree is collapsed (IMAP of an Outlook account in this case)), when you close the message tab, the account tree is expanded.  Very annoying.  I'm not interested in all of the Outlook folders that IMAP gets, thus the nicety of using smart folders and having this portion of the tree collapsed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0
Fixed by bug 536042.
Assignee: nobody → sid.bugzilla
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1a1
(Assignee)

Updated

7 years ago
Flags: in-testsuite+
blocking-thunderbird3.0: needed → .1+
Whiteboard: [fixed by bug 536042]
(Assignee)

Updated

7 years ago
status-thunderbird3.0: --- → .1-fixed
You need to log in before you can comment on or make changes to this bug.