push latest version of getpersonas.com to production (r56028)

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: Other
--
critical
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: myk, Assigned: fox2mike)

Tracking

other
All
Other
Dependency tree / graph
Bug Flags:
needs-downtime +

Details

(Whiteboard: 11/12/2009 @ 7pm)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
The latest version of the production branch of getpersonas.com should get pushed to production to pick up the fix for bug 527710, which adds a username property to the JSON feeds that supports a new feature in the upcoming version 1.4 of the Personas extension.

A number of other changes have been made on the getpersonas.com trunk, but only this one change is to be pushed in this particular push.  Ryan is going to manually apply the change to the production branch of the website repository before the push to make sure it's the only change that gets pushed to production (bug 527791).

If at all possible, please do this push during the regularly scheduled maintenance window this Thursday, November 12.
(Reporter)

Updated

8 years ago
Depends on: 527791

Updated

8 years ago
Flags: needs-downtime+
Whiteboard: 11/12/2009 @ 7pm
r527710
Summary: push latest version of getpersonas.com to production → push latest version of getpersonas.com to production (r527710)
(In reply to comment #1)
> r527710

wrong. r55884
Summary: push latest version of getpersonas.com to production (r527710) → push latest version of getpersonas.com to production (r55884)
(Assignee)

Comment 3

8 years ago
I can grab this.
Assignee: server-ops → shyam
Created attachment 411696 [details]
migration script to update personas

Stick it in the root personas directory (/var/www/personas on sm-personas01) and run php migration.php. Will rebuild all json files.
Added script to retrofit all the index_1.json files. Drop it into /var/www/personas (or whatever the svn root is on production) and run it as sudo.

Comment 6

8 years ago
Are you asking for a prod push or a stage push (sm-personas01)?
prod push - my comment about sm-personas01 was just that that was where it would go on stage, so likely where it goes in prod.
Blocks: 526556
New svn revision, have another isolated page for mozilla.com that can go out with this push. 

r55963

Page is external/mozilla/students.php, self-contained like the others in external/mozilla, no apache config changes needed.
Summary: push latest version of getpersonas.com to production (r55884) → push latest version of getpersonas.com to production (r55963)
(Assignee)

Updated

8 years ago
Depends on: 527782
Another svn revision (sorry for these changes coming in late)

r56028

Removes some functionality, the rest is l10n updates.
Summary: push latest version of getpersonas.com to production (r55963) → push latest version of getpersonas.com to production (r56028)
(Assignee)

Comment 10

8 years ago
[root@mradm02 getpersonas.com]# svn up -r 56028
A    server/external/mozilla/students.php
U    server/external/mozilla/footer.php
 U   server/external/mozilla/index.php
U    server/external/mozilla/header.php
 U   server/external/mozilla
UU   server/admin/pending.php
UU   server/lib/personas_functions.php
Updated to revision 56028.

Updated fine. 

Running the migration script now, it's spitting out numbers.
(Assignee)

Comment 11

8 years ago
Done.

67349 <- was the last one.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

8 years ago
Looks great, thanks Shyam!
Status: RESOLVED → VERIFIED
re-opening, there seems to be some regressions. These urls used to work:

http://www.getpersonas.com/en-US/external/mozilla
http://www.getpersonas.com/en-US/external/mozilla/firstrun.php (loads incorrect page)

And this url was going live with the push:
http://www.getpersonas.com/en-US/external/mozilla/students.php

From what I can tell, it appears the apache config was modified/reverted to an earlier state.

In order for the above urls to work properly, this needs to be in the vhost file:

AliasMatch ^/([a-zA-Z-]+/)?external/(.*) /path/to/personas/server/external/$2

And make sure this is not in the vhost file:
RewriteRule ^/(?:\w{2,3}(?:-\w{2}(?:-mac)?)?/)?external/mozilla/?
/mnt/netapp/personas/server/external/mozilla/index.php

This was filed in bug 527120 previously.
Severity: major → critical
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Also found a bug, will need a svn up, will get rev # in a min.

Updated

8 years ago
Blocks: 521532

Updated

8 years ago
Blocks: 521531

Updated

8 years ago
Blocks: 523782

Updated

8 years ago
Blocks: 523778
(In reply to comment #14)
> Also found a bug, will need a svn up, will get rev # in a min.

r56061
(Assignee)

Comment 16

8 years ago
[root@mradm02 getpersonas.com]# svn up -r 56061
UU   server/external/mozilla/students.php

And apache changes pushed out.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Looks awesome, thanks Shyam!
Status: RESOLVED → VERIFIED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.