Need the ability to run httpd.js on a non-loopback connection

RESOLVED DUPLICATE of bug 544097

Status

Testing
General
RESOLVED DUPLICATE of bug 544097
8 years ago
25 days ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

1.9.2 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
For some of the test-agent stuff we are doing in Orodruin, we'd like to use httpd.js to serve the test web pages remotely from the device under test.  Therefore, we need the ability to launch httpd.js with a given IP address and port via XPCShell, perhaps something like this:

xpcshell -e 'var gIpAddress = 192.168.0.1:8889' -f httpd.js

I think Joel already has a patch for something like this.

Comment 1

8 years ago
In response to the bug summary:

This is probably about ten or twenty lines of code in httpd.js plus half a dozen lines to add it to the nsIHttpServer interface along with documentation.  I suggest changing start(port) to this:

  void start(in long port, in boolean allowExternalConnections);

Then just pass allowExternalConnections (maybe negated) to the ServerSocket constructor call there to enable external connections.

However, in response to comment 0:

I'm not sure I understand what you actually want with respect to the IP address and port.  You specify the port when you start up the server; the IP address/hostname you modify using the identity attribute of the server.  Why does any of that require changes to httpd.js?
Component: New Frameworks → httpd.js
QA Contact: new-frameworks → httpd.js
I will be handling this in bug 544097.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 544097
(Assignee)

Updated

25 days ago
Component: httpd.js → General
Product: Testing → Testing
You need to log in before you can comment on or make changes to this bug.