Replacing a search engine/tool/plugin not user friendly

UNCONFIRMED
Unassigned

Status

()

enhancement
UNCONFIRMED
10 years ago
5 months ago

People

(Reporter: ottodv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091105 Fedora/3.5.5-1.fc11 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091105 Fedora/3.5.5-1.fc11 Firefox/3.5.5

When trying to replace/update a search engine/tool/plugin Firefox throws an error:

"Firefox could not install the search plugin from "https://addons.mozilla.org/en-US/firefox/downloads/latest/14787/addon-14787-latest.xml?src=addondetail" because an engine with the same name already exists."

If a user wants to replace a search plugin, currently the user first needs to go to the "Manage Search Engines" menu, then find the search plugin he/she wants to replace (which can be difficult if the number of search plugins is very large), delete it and then install again.

It would be much more user friendly to offer the user the option to replace the existing search plugin.

Reproducible: Always

Steps to Reproduce:
1. Go to https://addons.mozilla.org/en-US/firefox/addon/14787 (example)
2. Click the "+ Add to Firefox" button.
3. See the error message appear.
Actual Results:  
Error message thrown:

"Firefox could not install the search plugin from "https://addons.mozilla.org/en-US/firefox/downloads/latest/14787/addon-14787-latest.xml?src=addondetail" because an engine with the same name already exists."

Expected Results:  
A more user friendly message would be:

""https://addons.mozilla.org/en-US/firefox/downloads/latest/14787/addon-14787-latest.xml?src=addondetail" is trying to install a search plugin with the same name as one that already exists. Are you sure you want to replace it?"

Provide a yes/no choice.

As a developer of search plugins this would save me a lot of time, but it also avoids problems when you tell normal users that there is a new version and they want it immediately (without waiting for the auto update) as most get confused by an error message they don't expect (I have had such feedback and wish I wouldn't have to explain how to replace a search plugin - it should just work for them.)
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353056
Reporter

Comment 2

10 years ago
Sorry this is not a duplicate of bug 353056

This bug is an enhancement requested for a user to be able to replace *any* search engine in a user friendly way, by providing a yes/no choice to replace an existing search engine when installing a new version of the same search engine.

It is not about not being able to replace built in search engines as bug 353056 is. That's an entirely different problem.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Comment hidden (off-topic)
Comment hidden (off-topic)
You need to log in before you can comment on or make changes to this bug.