If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Window minimized through keyboard shortcut doesn't get restored through menu

RESOLVED DUPLICATE of bug 510221

Status

()

Firefox
Menus
--
minor
RESOLVED DUPLICATE of bug 510221
8 years ago
8 years ago

People

(Reporter: pfmoose, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2

When I minimize a window, any firefox window, using the command + M keyboard shortcut, the window minimizes just fine, but when I click on the menu item "Window" and select that window to restore it, it doesn't do anything. I have to click the minimized window from the Dock so that it actually gets restored. This problem also occurs when I don't use the keyboard shortcut, so for example when I click the amber button to minimize, or when I double-click the title bar or when I click on "Window" and then "Minimize". It simply does not get restored unless I click the minimized window in the Dock.

Reproducible: Always

Steps to Reproduce:
1.Minimize any window in any manner desirable (keyboard shortcut, menu item, amber button, etc.)
2.Click on Menu Item "Window" and select the window that was minimized
3.Sit and watch while nothing happens, repeat as many times as you wish, it still won't happen.
Actual Results:  
Absolutely nothing.

Expected Results:  
It should have restored the window I had minimized and then selected from the Menu.





  Application Basics



        Name

        Firefox



        Version

        3.6b2



        Profile Directory



          Show in Finder



        Installed Plugins



          about:plugins



        Build Configuration



          about:buildconfig



  Extensions



        Name



        Version



        Enabled



        ID



        Adblock Plus

        1.1.1

        true

        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}



        Better Gmail 2

        0.9.5

        true

        bettergmail2@ginatrapani.org



        DownloadHelper

        4.6.4

        true

        {b9db16a4-6edc-47ec-a1f4-b86292ed211d}



        DownThemAll!

        1.1.7

        false

        {DDC359D1-844A-42a7-9AA1-88A850A938A8}



        FEBE

        6.3

        false

        {4BBDD651-70CF-4821-84F8-2B918CF89CA3}



        Firefox PDF Plugin for Mac OS X

        1.1.2

        true

        colesbury@gmail.com



        Google Gears

        0.5.33.0

        true

        {000a9d1c-beef-4f90-9363-039d445309b8}



        Greasemonkey

        0.8.20090920.2

        true

        {e4a8a97b-f2ed-450b-b12d-ee082ba24781}



        Juice

        1.1 BETA

        false

        juice@juiceapp.com



        ReminderFox

        1.9.1

        false

        {ada4b710-8346-4b82-8199-5de2b400a6ae}



        Taboo

        0.6.0

        false

        taboo@runningfrombears.com



        Twones Tracker

        0.6.17

        true

        twonestracker@twones.com



        Wired-Marker

        3.1.09060400

        false

        {e36db930-f18d-4449-b45f-e286cfb9e03a}



        Xmarks

        3.3.2

        true

        foxmarks@kei.com



        Add-on Compatibility Reporter

        0.1

        true

        compatibility@addons.mozilla.org



  Modified Preferences



      Name



      Value



        accessibility.typeaheadfind.flashBar

        0



        browser.history_expire_days.mirror

        180



        browser.places.importBookmarksHTML

        false



        browser.places.smartBookmarksVersion

        2



        browser.startup.homepage

        https://mail.google.com/mail/#inbox|http://www.facebook.com/home.php#/home.php?ref=logo|http://www.tuenti.com/#m=home&fu…



        browser.startup.homepage_override.mstone

        rv:1.9.2b2



        extensions.checkCompatibility

        false



        extensions.lastAppVersion

        3.6b2



        network.cookie.prefsMigrated

        true



        places.last_vacuum

        1257627502



        print.macosx.pagesetup-2

        AAAdsDw/eG1sIHZlcnNpb249IjEuMCIgZW5jb2Rpbmc9IlVURi04Ij8+CjwhRE9DVFlQRSBwbGlzdCBQVUJMSUMgIi0vL0FwcGxlIENvbXB1dGVyLy9EVEQg…



        print.print_bgcolor

        false



        print.print_bgimages

        false



        print.print_command



        print.print_downloadfonts

        false



        print.print_evenpages

        true



        print.print_in_color

        true



        print.print_margin_bottom

        0.5



        print.print_margin_left

        0.5



        print.print_margin_right

        0.5



        print.print_margin_top

        0.5



        print.print_oddpages

        true



        print.print_orientation

        0



        print.print_pagedelay

        500



        print.print_paper_data

        0



        print.print_paper_height

        11.00



        print.print_paper_size_type

        1



        print.print_paper_size_unit

        0



        print.print_paper_width

        8.50



        print.print_printer



        print.print_reversed

        false



        print.print_scaling

        1.00



        print.print_shrink_to_fit

        true



        print.print_to_file

        false



        print.print_unwriteable_margin_bottom

        56



        print.print_unwriteable_margin_left

        25



        print.print_unwriteable_margin_right

        25



        print.print_unwriteable_margin_top

        25



        privacy.sanitize.migrateFx3Prefs

        true



        security.warn_viewing_mixed

        false
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 510221
You need to log in before you can comment on or make changes to this bug.