Too many redraws which changing combobox elements dynamically

VERIFIED DUPLICATE of bug 27233

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 27233
18 years ago
18 years ago

People

(Reporter: Biswapesh Chatterjee, Assigned: clayton)

Tracking

({perf})

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: All
Steps to Reproduce: To to http://bugzilla.mozilla.org/query.cgi and 
select 'Browser'.
Expected result: There should be a wait as the new values 
for 'Version', 'Component' and 'Target Milestone' and figured out and there 
should be one re-draw since the combo-box sizes change because of the new 
values (this is the IE5/NS4.x behaviour).
Actual Result: There are way too many redraws as a result of which the relevant 
area gets messed up totally till all the elements are selected.
It seems that for each new entry, the combos try to resize themselves.
Reproducible: Always.
(Reporter)

Comment 1

18 years ago
Adding 'perf' keyword - not sure about whether this belongs to layout - pl. 
reassign as necessary.

Thanks.
Biswa.
Keywords: perf

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Duplicate.

*** This bug has been marked as a duplicate of 27233 ***
(Reporter)

Comment 3

18 years ago
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.