Closed Bug 527941 Opened 11 years ago Closed 11 years ago

Row un-highlights when moving cursor in that same row

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: aakashd, Unassigned)

Details

Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b3pre) Gecko/20091111 Firefox/3.6b2pre Fennec/1.0b5

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091111 Firefox/3.7a1pre Fennec/1.0b5

Note: This is a follow-up bug from bug 525997

Steps to Reproduce:
1. Open up the awesome bar by clicking on the url field.
2. Mousedown and hold on a row
3. Pan horizontally within the row
4. Mousedown and hold on a row again
5. Pan vertically

Actual Results:
When panning horizontally, the row un-highlights itself

Expected Results:
When panning horizontally on the same row, the row should still be highlighted.
Flags: in-litmus?
Sorry, instead of filing another bug, I'd also like to add that the row un-highlights when panning vertically while still on that row. I think the inherent purpose of bug 525997 was to get rid of highlighting behavior when the position of the cursor had nothing to do with the row that was initially moused-down.
Summary: Row un-highlights when moving cursor horizontally while on that same row → Row un-highlights when moving cursor in that same row
tracking-fennec: --- → ?
Even when we pan over the same row, it should not be highlighted because when we detect a pan we cancel the next click.
Highlighting a row has a sense when a click has an effect on it, only (imo).
(In reply to comment #1)
> Sorry, instead of filing another bug, I'd also like to add that the row
> un-highlights when panning vertically while still on that row. I think the
> inherent purpose of bug 525997 was to get rid of highlighting behavior when the
> position of the cursor had nothing to do with the row that was initially
> moused-down.

Not exactly -- the idea is to get as close as we can to having no highlighting when what the user is trying to do it pan rather than tap, while still not delaying tap highlighting too much.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
Alright, I'm not sure that this is invalid, but this isn't going to be fixed. I'll verify as such.
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.