any file (jpg) gets locked after uploading, files uploaded afterwards get locked too.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: alex, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Hello! 
happens to any file!! 
we upload a file, and the file gets locked by Firefox.exe so we cannot edit the file after that. we have to close Firefox then open it up again so that the file gets unlocked, by unlocked we mean the typical windows alert box that says the following:

----------------------------------------------------------------------
|Error deleting file or folder
|---------------------------------------------------------------------
|Cannot delete bg_x.jpg: It is being used by another person or program.
|Close any programs that might be using the file and try again.
|
----------------------------------------------------------------------

after closing Firefox the file(s) can be deleted. our workaround is to create new files and rename them on the server. 
We are using a modem to connect to the internet, a bit prehistoric but this is all we have. maybe the slow speed is what is causing the problem.
thanx!


Reproducible: Always

Steps to Reproduce:
1.upload a file (jpg/html)
2.try to update the file (photoshop/eclipse)
3.resave the file/delete the file
Actual Results:  
typical windows alert box that says the following:

----------------------------------------------------------------------
|Error deleting file or folder
|---------------------------------------------------------------------
|Cannot delete bg_x.jpg: It is being used by another person or program.
|Close any programs that might be using the file and try again.
|
----------------------------------------------------------------------


Expected Results:  
no alert box and just save the file as normal.

Comment 1

9 years ago
Where are you uploading the file to? Many uploaders are created using plugins these days, commonly Flash or Java based. As such this might be an Adobe or Sun bug.
Do you use Firebug ?
Doy ou get the same issue in the Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 3

9 years ago
Hello again!
sorry i forgot to mention the upload page is a normal upload form provided by our host, hostgator. we cannot alter that html. i will look into the html to see if there is any mistype or error. It worked fine until today. i updated my version of firefox yesterday and havent noticed the bug until now.
we do not use firebug, should we?
we will try using safemode tomorrow.

Comment 4

9 years ago
Hi! I regularly have this problem uploading files to Joomla! It applies to any file type. Joomla's Flash uploader is disabled, so this is a standard HTML upload, as far as I can see. 

Firefox 3.5 with DOM inspector 2.0.4. No Firebug

Comment 5

9 years ago
Confirming this as well with HTML upload forms. 
Craigslist uploads can be used for testing. 
Firefox will lock multiple images until the app is closed.

Updated

8 years ago
Version: unspecified → 3.5 Branch
closing this since we dont support 3.5 anymore, feel free to open this bug if it reproducible in current version of Firefox

http://getfirefox.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.