[mozmill] Fix broken tests under testLayout (Amazon, Yahoo)

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 411739 [details] [diff] [review]
Patch v1

Two tests under testLayout (Amazon and Yahoo) are failing because the layout has been changed a bit. Further Yahoo is redirecting to a local version too so we have to make sure to load the correct page before starting the test.
Attachment #411739 - Flags: review?(adesai)
(Assignee)

Updated

9 years ago
Blocks: 527983
(Assignee)

Updated

9 years ago
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Comment on attachment 411739 [details] [diff] [review]
Patch v1

The changes made for testCheckAmazon run fine on OSX and XP, testCheckYahoo fails on a check of assertJS("subject.indexOf('" + url + "')....

I get the following failure: http://pastebin.mozilla.org/683247 through IDE.
Attachment #411739 - Flags: review?(adesai) → review-
(Assignee)

Comment 2

9 years ago
Aakash, have you installed Mozmill 1.3b1? It's a new feature in that version so we can use the subject there too. Looks like you have an older version.
(Assignee)

Comment 3

9 years ago
(In reply to comment #2)
> Aakash, have you installed Mozmill 1.3b1? It's a new feature in that version so
> we can use the subject there too. Looks like you have an older version.
(Assignee)

Updated

9 years ago
Attachment #411739 - Flags: review- → review?(adesai)
Comment on attachment 411739 [details] [diff] [review]
Patch v1

Downloaded and installed 1.3 and they're working fine now.
Attachment #411739 - Flags: review?(adesai) → review+
(Assignee)

Comment 5

9 years ago
Sounds good. So you didn't upgraded the pyPI package? Would be great if we could talk about that beside this bug.

Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/ab95dbad9adf
http://hg.mozilla.org/qa/mozmill-tests/rev/05e5c3724fc3
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Keywords: regression
(Assignee)

Updated

9 years ago
Whiteboard: [mozmill-test-failure]
(Assignee)

Comment 6

8 years ago
Mass move of Mozmill Test related project bugs to newly created components. You can filter out those emails by using "Mozmill-Tests-to-MozillaQA" as criteria.
Component: General → Mozmill Tests
Product: Firefox → Mozilla QA
QA Contact: general → mozmill-tests
Version: 3.5 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.