Updates disabled when running as standard user

RESOLVED DUPLICATE of bug 407875

Status

()

defect
RESOLVED DUPLICATE of bug 407875
10 years ago
10 years ago

People

(Reporter: Wulf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2

The "Check for Updates..." menu-item is disabled (grayed-out) and updates aren't automatically found when running as a standard user, but works fine when Firefox is opened with "Run as administrator".

Reproducible: Always

Steps to Reproduce:
1. Open Firefox as a standard user.
2. Try to check for updates by using Help > Check for Updates...
Actual Results:  
Menu-item is disabled.

Automatic update checking doesn't work.

Expected Results:  
Menu-item is enabled, has a UAC shield icon next to it, and attempts elevation if an update is found.

Automatic update checking should attempt to elevate if an update is found.

Happens for me in both 3.5 and 3.6b2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407875
You need to log in before you can comment on or make changes to this bug.