exceptions keep spewing: nsIPref.GetBoolPref

VERIFIED DUPLICATE of bug 22163

Status

()

Core
Preferences: Backend
P3
normal
VERIFIED DUPLICATE of bug 22163
18 years ago
18 years ago

People

(Reporter: R.K.Aa., Assigned: dveditz)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
2000091506 linux m18

when clicking in url field i get
JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarLeftClickHandler :: line 2128"
 data: no]


when changing focus between windows i get

JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarBlurHandler :: line 2137"
data: no]


when trying to open files from local disk i get errors as well, some are the
same, some new:

JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarBlurHandler :: line 2137"
data: no]
--
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "uncaught exception: [Exception... "Component
returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPref.GetBoolPref]"
nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: URLBarBlurHandler :: line 2137"
data: no]" {file: "/tmp/package/components/nsFilePicker.js" line: 168}]"
nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location:
"JS frame :: /tmp/package/components/nsFilePicker.js :: anonymous :: line 168"
data: yes]
*****
(Reporter)

Comment 1

18 years ago
changing summary to reflect that this happened while opening files while offline
(normally using a modem connection - this was disconnected at the time)
Summary: problems with URL bar (?) causes havoc → can't open local files while offline. URL bar related?
claudius/radha, either of you see this? not sure who'd own it...
also recently saw these exceptions being continually spewed while i'm in the
Preferences dialog. cc'ing anthonyd, the person who last touch lin 2137 in
navigator.js. dan, is this a backend pref issue that could be fixed?
Assignee: ben → dveditz
Component: XP Apps: GUI Features → Preferences: Backend
Keywords: nsbeta3, regression
Summary: can't open local files while offline. URL bar related? → exceptions keep spewing: nsIPref.GetBoolPref
(Reporter)

Comment 4

18 years ago
after looking more at this i think it's two different bugs.
the URLBarLeftClickHandler thingie is displaying each time i change focus
between windows - regardless of what i've done before.

The inability to open files while offline is probably "something completely
different".

Comment 5

18 years ago
The 'nsIPref.GetBoolPref' related exception is covered under bug #22163 (looks
like part of a patch didn't get properly checked in).

As far as the 'opening files while offline', I can do this without error on
linux (as well as on win32 and mac, although nsFilePicker.js is not used on
those platforms).

So this bug is part DUPLICATE, and part WORKSFOR(jrgm). Perhaps R.K. could open
a new bug on the offline issue, and leave the distraction of the missing pref
behind.
(Assignee)

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 22163 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified dupe of reopened bug 22163: "on a mousedown focus change in text
fields, selection must be collapsed"
If you still see the WorkForMe part of this bug, please, feed a new bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.