Closed Bug 528299 Opened 12 years ago Closed 11 years ago

"Customize toolbar" box missing addon specific icons. Icons also disappeared from toolbar

Categories

(Firefox :: Extension Compatibility, defect)

3.6 Branch
x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: scutterman_scutterman, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2 (.NET CLR 3.5.30729)

I have several extensions (adblock plus, relby, exit button firefox) that have buttons/icons that can be added to the toolbar via the "customise toolbar" box. Recently I noticed all custom buttons had disappeared from both the toolbar and the "customize toolbar" box.

Attempts to fix include uninstalling/reinstalling addons, restarting windows, checking google, and checking a previous build of firefox (3.5.5 - Missing from there as well).

All three addons appear compatible with both FF 3.6 B2 and FF 3.5.5

Reproducible: Always

Steps to Reproduce:
1. Uninstall/reinstall addon
2. Open "Customize toolbar" box
Actual Results:  
Only default icons/buttons/etc. appear

Expected Results:  
default icons/buttons/etc. appear as well as custom ones placed there by addons
I am running  Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3pre) Gecko/20091112 Namoroka/3.6b3pre GTB6. I installed ABP and Exit Firefox in a relatively new profile. For me the Exit button does show in the set of icons available, but there is no icon available for Adblock Plus. Did you install or uninstall any themes or personas lately?
Adblock plus has something within the options to set it to either the toolbar, the status bar, or both. I forgot that when posting earlier.

After posting I created a blank profile and added Reliby and Exit Button Firefox, both worked fine. I then went onto my main profile and uninstalled a lot of addons, leaving just ones that I have been using for a long time and are stable/compatible, plus a few that were not listed as compatible but were disabled. No change.

I had a version of utopia that I wasn't using (not listed as compatible so I switched to default) which I uninstalled with the other incompatible extensions.

Tomorrow I plan to copy out my list of extensions on my main profile and add them one by one into the testing one. I'll re-post back here with the results.
[[In Test Profile]]
[Installed Yesterday]
Exit Button Firefox
Reliby

[Installed Today]
Adblock Plus
British English Dictionary
Chatzilla
Download Statusbar
Firebug
Live Click
Net Video Hunter

[I Disabled extension compatibility checking at this point]

Add-on Compatibility Reporter 0.1 (uninstalled in main profile)
The [Unofficial] Facebook "Dislike" Add-on 1.5.1 (buttons disappeared. Looks like it was an addon problem)

[[In Main Profile]]
[Disabled]
The [Unofficial] Facebook "Dislike" Add-on

The buttons are now displaying in the customize toolbar box, and can be added with no problems.

I was using this addon with no problems earlier in the day. An update must have been pushed without me seeing or a glitch just got triggered or something.
Version: unspecified → 3.6 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.