Closed Bug 528404 Opened 10 years ago Closed 7 years ago

Intermittent timeout in e4x/XML/regress-324688.js

Categories

(Core :: JavaScript Engine, defect)

x86
Windows Server 2003
defect
Not set

Tracking

()

RESOLVED WONTFIX
mozilla1.9.3a3

People

(Reporter: philor, Assigned: bc)

References

Details

(Keywords: intermittent-failure, Whiteboard: [test disabled, should be rewritten])

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258055107.1258060103.11970.gz#err60
WINNT 5.2 mozilla-central opt test everythingelse on 2009/11/12 11:45:07
"s: moz2-win32-slave24"

begin test: e4x/XML/regress-324422-1.js
BUGNUMBER: 324422
STATUS: Do not crash creating XML object with long initialiser
STATUS: 10485760
Caught InternalError: script stack space quota is exhausted
 PASSED! Section 1 of test - Do not crash creating XML object with long initialiser
REFTEST TEST-PASS | file:///e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=e4x/XML/regress-324422-1.js | Section 1 of test - Do not crash creating XML object with long initialiser  item 1
REFTEST TEST-KNOWN-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=e4x/XML/regress-324422-2.js | (SKIP)
begin test: e4x/XML/regress-324688.js
STATUS: No Syntax Error when trailing space and XML.ignoreWhitespace true
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-opt-unittest-everythingelse/build/jsreftest/tests/jsreftest.html?test=e4x/XML/regress-324688.js | timed out waiting for reftest-wait to be removed (after onload fired)
Whiteboard: [orange]
This test completes in a second or so in my builds. I would rather not mark this test as random if the cause is a regression rather than randomness. If you see additional failures of this test, please make sure that the rest of the tests are green.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261622674.1261626070.17244.gz
WINNT 5.2 mozilla-central opt test everythingelse on 2009/12/23 18:44:34
s: win32-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262962373.1262964530.7354.gz

OS X 10.5.2 mozilla-central test everythingelse [testfailed] Started 06:52, finished 07:29
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264720678.1264722213.9030.gz
WINNT 5.2 mozilla-central opt test jsreftest on 2010/01/28 15:17:58
s: win32-slave13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265672136.1265674710.22586.gz
OS X 10.5.2 mozilla-central opt test jsreftest on 2010/02/08 15:35:36
s: bm-xserve11
This test is fragile. Lets disable it until it can be rewritten.
Attachment #425964 - Flags: review?(sayrer)
Attachment #425964 - Flags: review?(sayrer) → review+
http://hg.mozilla.org/tracemonkey/rev/547ef92c3fd2

please merge to mc when appropriate.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265844283.1265845057.24216.gz
OS X 10.5.2 mozilla-central opt test jsreftest on 2010/02/10 15:24:43
s: bm-xserve11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265933566.1265936489.1966.gz
OS X 10.5.2 mozilla-central opt test jsreftest on 2010/02/11 16:12:46
s: bm-xserve07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266522051.1266522924.20136.gz
OS X 10.5.2 mozilla-central opt test jsreftest on 2010/02/18 11:40:51
s: bm-xserve12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266535580.1266538720.18203.gz
WINNT 5.2 mozilla-central opt test jsreftest on 2010/02/18 15:26:20
s: win32-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266600529.1266601769.9358.gz
OS X 10.5.2 mozilla-central opt test jsreftest [testfailed] Started 09:28, finished 09:50
http://hg.mozilla.org/mozilla-central/rev/547ef92c3fd2
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a3
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [orange] → [test disabled, should be rewritten]
Whiteboard: [test disabled, should be rewritten] → [orange][test disabled, should be rewritten]
Whiteboard: [orange][test disabled, should be rewritten] → [test disabled, should be rewritten]
e4x support has been removed (bug 788293) and this test no longer exists.
Status: REOPENED → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.