Non ASCII fragment identifier does not work

VERIFIED DUPLICATE of bug 58819

Status

()

Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 58819
18 years ago
17 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

({intl})

Trunk
mozilla0.9.1
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This bug was reported by Martin Duerst at W3.
He saw this using a Mac mozilla build, but I also can reproduce this using
a Win32 build.

Below is his email about this problem.

On the page http://www.sfc.keio.ac.jp/ORF2000/demo.html,

Greek letters in a Japanese (SJIS) page are used as fragment identifiers.

Mozilla (Mac, 2000081721 build) uses SJIS to produce the fragment
identifier, e.g. pointing at the first link in the page, it displays
http://www.sfc.keio.ac.jp/ORF2000/demo.html#%B3%CD for the lower-case
omega. But then it doesn't find this location.

What it should do is to use UTF-8 to calculate the fragment identifier,
which would result in a formal URI of 
http://www.sfc.keio.ac.jp/ORF2000/demo.html#%CE%BF. Either this, or
preferably just the omicron itself, should be displayed. When looking
for the corresponding name or id in the page, it should then of course
also interpret these names/ids in UTF-8 (or behave as if it did).
(Assignee)

Comment 1

18 years ago
Reassign to Frank.
Assignee: nhotta → ftang

Updated

17 years ago
Keywords: intl

Comment 2

17 years ago
Change the summary from "Greek letters in a Japanese (SJIS) page are used as
fragment identifiers"  to
"Non ASCII fragment identifier does not work"
I do not 100% agree with the following comment
>What it should do is to use UTF-8 to calculate the fragment identifier,
>which would result in a formal URI of
>http://www.sfc.keio.ac.jp/ORF2000/demo.html#%CE%BF.
The important thing is we should locate the in-document Anchor

What we should do is we should convert the %B3%CD back to Unicode before we find
the A from DOM. Or we should match %B3%CD in the DOM code.

Browser related issue. Reassign to nhotta.
Mark it as P3 mozilla0.9.1

Assignee: ftang → nhotta
Keywords: nsbeta1
Summary: Greek letters in a Japanese (SJIS) page are used as fragment identifiers → Non ASCII fragment identifier does not work
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 58819 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.