Closed Bug 528472 Opened 10 years ago Closed 10 years ago

Hide tooltips in desktop Fennec builds

Categories

(Firefox for Android Graveyard :: General, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Aleksej, Assigned: mbrubeck)

Details

(Keywords: access, Whiteboard: [fennecb5testday])

Attachments

(3 files)

Todays nightly builds on Linux x86.

As I said in bug 520209, on my monitor, black color and the window color are almost the same.
That bug is about active tab indication; it is much worse with text even if the colours are less similar on other devices.

Not reading a tooltip can lead to things like posting the current URL to identi.ca accidentally after installing a new extension.
Whiteboard: [fennecb5testday]
Severity: normal → minor
Attached patch patchSplinter Review
We don't show tooltips on our target platforms - they only show up in the emulator.

This patch hides tooltips in the emulator too.  There might be a better way to do this, but it didn't work when I tried things like just adding "tooltip { visibility: hidden; }" to the stylesheet.  And there's sometimes a brief flicker of a rectangle the first time a tooltip would appear.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #450779 - Flags: review?(mark.finkle)
Summary: Black tooltips hard to read on the almost black background. → Hide tooltips in desktop Fennec builds
Version: 1.9.2 Branch → Trunk
Attachment #450779 - Flags: review?(mark.finkle) → review+
pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/c1d9961f4677
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Aleksej, can you go ahead and verify this when you get the chance. I'm having a hard time reproducing it.
I am not sure this is definitive, because there is bug 571438, but in build 20100615022638, the first would-be-tooltip in a session does appear for a moment (and no more until restart).
(In reply to comment #5)
That bug is fixed, but tooltip behaviour is similar with build 20100619020550, except that it is not always limited to one blink per session (happens again for the icon area after loading a different AMO page).
You need to log in before you can comment on or make changes to this bug.