release_master.py contents should be factored out somewhere

RESOLVED DUPLICATE of bug 553300

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 553300
9 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: catlee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [automation])

(Reporter)

Description

9 years ago
release_master.py is currently copied around in a few places: staging and product firefox configs, seamonkey configs, thunderbird configs. It'd be good to factor this out somewhere and have it handle all the cases, like we've done in the past with the generate* functions in buildbotcustom.misc. It's currently a bit of a PITA to keep in sync.

Comment 1

9 years ago
If we do that, we at least need a good way of doing partial respins for failure recovery in a way that doesn't need editing release_master.py or its equivalent (with dummy factories, etc.)

Comment 2

8 years ago
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3

Updated

8 years ago
Whiteboard: [automation]
(Assignee)

Comment 3

8 years ago
This is being done as part of the move to buildbot 0.8.0
Assignee: nobody → catlee
Depends on: 553300
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553300
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.