Set focus to text entry field in Secret Phrase dialog

RESOLVED FIXED in 1.1

Status

Cloud Services
Firefox Sync: UI
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: tracy, Assigned: zpao)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
When presented with the Secret Phrase dialog on sign in focus is not in the text entry field.  The user shouldn't have to click (or tab into) the text field. Focus should already be there.

Updated

9 years ago
Duplicate of this bug: 529107

Updated

8 years ago
Assignee: nobody → mconnor
Component: General → Firefox UI
OS: Mac OS X → All
QA Contact: general → firefox
Hardware: x86 → All
Target Milestone: --- → 1.1
Created attachment 426773 [details] [diff] [review]
Patch v0.1

I had time on my hands so I did this.
Assignee: mconnor → paul
Status: NEW → ASSIGNED
Attachment #426773 - Flags: review?
Attachment #426773 - Flags: review? → review?(mconnor)

Updated

8 years ago
Attachment #426773 - Flags: review?(mconnor) → review+
Pushed http://hg.mozilla.org/labs/weave/rev/fb3c5c1faca1
Call el.focus() when we change to passphase page, el.select() when there's a passphrase error.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.